summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-06-01 07:55:38 +0200
committerJeroen Roovers <jer@gentoo.org>2019-06-01 07:55:47 +0200
commit0bfb6da5565ee724cd302285a18cb5b0c70ee302 (patch)
treeb43eb5ed68fe0a2edbfed66927c83235dbc2dfbf /sci-calculators/units/units-2.17.ebuild
parentsci-calculators/units: Version 2.19 (diff)
downloadgentoo-0bfb6da5565ee724cd302285a18cb5b0c70ee302.tar.gz
gentoo-0bfb6da5565ee724cd302285a18cb5b0c70ee302.tar.bz2
gentoo-0bfb6da5565ee724cd302285a18cb5b0c70ee302.zip
sci-calculators/units: Old
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sci-calculators/units/units-2.17.ebuild')
-rw-r--r--sci-calculators/units/units-2.17.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/sci-calculators/units/units-2.17.ebuild b/sci-calculators/units/units-2.17.ebuild
deleted file mode 100644
index 4d61f6f6676c..000000000000
--- a/sci-calculators/units/units-2.17.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit eutils python-single-r1
-
-DESCRIPTION="Unit conversion program"
-HOMEPAGE="https://www.gnu.org/software/units/units.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="FDL-1.3 GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units_cur"
-REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- sys-libs/readline:=
- units_cur? (
- ${PYTHON_DEPS}
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- ${RDEPEND}
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-2.17-network-sandbox.patch
-)
-
-pkg_setup() {
- use units_cur && python-single-r1_pkg_setup
-}
-
-src_configure() {
- econf \
- --sharedstatedir="${EROOT}/var/lib" \
- ac_cv_path_PYTHON=no
-}
-
-src_compile() {
- emake ${PN}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc ChangeLog NEWS README
-
- # we're intentionally delaying this since 'make install' would
- # get confused if we shove 'units_cur' there, and there is no real
- # need to add more complexity for it
- if use units_cur; then
- sed \
- -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
- -e 's|^#!|&/usr/bin/python|g' \
- units_cur_inst > units_cur || die
- python_fix_shebang units_cur
- python_doscript units_cur
- fi
-}