summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 12:34:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:26:15 +0100
commitc43c76cb32bfff15f9f106e0d3c7a6c597477b67 (patch)
tree2bad364aa9ca5af7330e6fafdac09dc88d04bd26 /sci-calculators
parentnet-misc/qtm: Drop 1.3.19 (r0) (diff)
downloadgentoo-c43c76cb32bfff15f9f106e0d3c7a6c597477b67.tar.gz
gentoo-c43c76cb32bfff15f9f106e0d3c7a6c597477b67.tar.bz2
gentoo-c43c76cb32bfff15f9f106e0d3c7a6c597477b67.zip
sci-calculators/speedcrunch: Switch to cmake.eclass, fix appdata path
Drop PLOCALES/l10n hacks Fix DEPENDs Further implify src_install Use https Fix indendation Closes: https://bugs.gentoo.org/741206 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/speedcrunch/files/speedcrunch-0.12.0-appdata.patch26
-rw-r--r--sci-calculators/speedcrunch/speedcrunch-0.12.0-r1.ebuild40
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-calculators/speedcrunch/files/speedcrunch-0.12.0-appdata.patch b/sci-calculators/speedcrunch/files/speedcrunch-0.12.0-appdata.patch
new file mode 100644
index 000000000000..cf312944f907
--- /dev/null
+++ b/sci-calculators/speedcrunch/files/speedcrunch-0.12.0-appdata.patch
@@ -0,0 +1,26 @@
+From 3caeaa7eec01f64e769351355dff0fedd95a25fd Mon Sep 17 00:00:00 2001
+From: Felix Krull <f_krull@gmx.de>
+Date: Mon, 7 Aug 2017 16:19:22 +0200
+Subject: [PATCH] Install appdata file into new metadata path.
+
+*asturm 2021-02-28: Backported to 0.12.0.
+
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1fa32ac..fb333f4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -113,7 +113,7 @@
+ if(NOT WIN32)
+ set(SHAREDIR "share/")
+ set(MENUDIR "${SHAREDIR}/applications/")
+- set(APPDATADIR "${SHAREDIR}/appdata/")
++ set(APPDATADIR "${SHAREDIR}/metainfo/")
+ set(ICONDIR "${SHAREDIR}/pixmaps/")
+ set(BINDIR "bin")
+ else(NOT WIN32)
+--
+2.10.5
diff --git a/sci-calculators/speedcrunch/speedcrunch-0.12.0-r1.ebuild b/sci-calculators/speedcrunch/speedcrunch-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..cc9c48df2737
--- /dev/null
+++ b/sci-calculators/speedcrunch/speedcrunch-0.12.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg-utils
+
+DESCRIPTION="Fast and usable calculator for power users"
+HOMEPAGE="https://speedcrunch.org/"
+SRC_URI="https://bitbucket.org/heldercorreia/${PN}/get/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/heldercorreia-speedcrunch-ea93b21f9498/src"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qthelp:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-appdata.patch" )
+
+src_install() {
+ use doc && local HTML_DOCS=( ../doc/build_html_embedded/. )
+ cmake_src_install
+ doicon -s scalable ../gfx/speedcrunch.svg
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}