summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-01 04:32:34 +0000
committerSam James <sam@gentoo.org>2021-01-01 04:32:34 +0000
commitf9668b4fe4c289875bb573d5ce0bb057faca6f28 (patch)
treefe2ec4f130f39781872f66b2dc66ef2b2401b573 /sci-calculators
parentprofiles/package.mask: mask EOL branch of net-irc/unrealircd (diff)
downloadgentoo-f9668b4fe4c289875bb573d5ce0bb057faca6f28.tar.gz
gentoo-f9668b4fe4c289875bb573d5ce0bb057faca6f28.tar.bz2
gentoo-f9668b4fe4c289875bb573d5ce0bb057faca6f28.zip
sci-calculators/units: bump to 2.21
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/units-2.21.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index ba47bcea8d72..a40be723533b 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -2,3 +2,4 @@ DIST units-2.16.tar.gz 1178197 BLAKE2B 6de569cd70c8067be053c5acb0885f898b76252bf
DIST units-2.18.tar.gz 1248892 BLAKE2B b1dd86907ba6af3251577c533d6c39705ff4a8cdf099c15c61efaf7876ee9a4131212e09b3e9ca0f2355fc547256e33be4fcb9efc552b38e3e990e76b9465992 SHA512 2ae9f08acb03f2f443514800dafb454434d7d1a43497d2a937c2e9e8429f63d821be11ae3090693e8cadbd2f9cdeafba8f80c1671d84a9cceb0f72ad75d8cad7
DIST units-2.19.tar.gz 1271288 BLAKE2B b6d61661d88e8221d5689e7f1cdba357479d4e34c4c6fd51c336e76850521b3ad7d8f1bfd9ff8173917931151c8da2180928879be940358e35ae3e96a6e30765 SHA512 f28df8f0b95b53620d4d21ed369551b8510663ff3658293ba62de2722e7dc2d87506db7c65dc192e35f3c3a20842e8ed09ddaa7352532f7e3eaeab4c001061c8
DIST units-2.20.tar.gz 1309242 BLAKE2B 5321e6234cfe4514d1ebccec490e472ff64a0428bb2721f51e3ff626ddef7eec4b4e8822aa947da1f4ddca414078b617ba34308c86a71788f6d8a9ba20dd6846 SHA512 5292588fb7ea0ab12e45e5521a115a0eaba4e37378011677cbd80e6e17a6ffa5f388a57859c590b6d65460fc91a4ff33e6603e27d4909b8122d4ad3696c8600d
+DIST units-2.21.tar.gz 1308533 BLAKE2B 0a02979eafa21af759128ec72b11e1f532640c9d0e88ae8f389a1beb52d5a400cbd6294042aa4c7d8786c06c8ac4106a77c302805b8c5e3bb84d4134805fd517 SHA512 34bacff606f12aa5b2e59170f6b2142277aa1121d79610a51b57f07f17ae2dbdfbbb0e60be34522f367679cc152408f77c1ebb551016224d23f81c21f4b3ba62
diff --git a/sci-calculators/units/units-2.21.ebuild b/sci-calculators/units/units-2.21.ebuild
new file mode 100644
index 000000000000..f62e7185316e
--- /dev/null
+++ b/sci-calculators/units/units-2.21.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units-cur? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.17-network-sandbox.patch
+ "${FILESDIR}"/${PN}-2.20-readerror.patch
+)
+
+DOCS=( ChangeLog NEWS README )
+
+src_configure() {
+ econf \
+ --sharedstatedir="${EPREFIX}"/var/lib \
+ ac_cv_path_PYTHON=no
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ default
+
+ if use units-cur; then
+ sed \
+ -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_foreach_impl python_doscript units_cur
+ fi
+}