summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-04 16:23:20 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-04 18:38:14 +0100
commitab3cb84f3330df13a11acbaf00ca4b2e4a20a0a8 (patch)
treef67d13de973c24129a2c98ea34705b09628add26 /sci-chemistry/avogadro2/files
parentsci-libs/clblast: add version 1.5.2 (diff)
downloadgentoo-ab3cb84f3330df13a11acbaf00ca4b2e4a20a0a8.tar.gz
gentoo-ab3cb84f3330df13a11acbaf00ca4b2e4a20a0a8.tar.bz2
gentoo-ab3cb84f3330df13a11acbaf00ca4b2e4a20a0a8.zip
sci-chemistry/avogadro2: add version 1.95.1
Closes: https://bugs.gentoo.org/834325 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-chemistry/avogadro2/files')
-rw-r--r--sci-chemistry/avogadro2/files/avogadro2-1.95.1-qttest.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/sci-chemistry/avogadro2/files/avogadro2-1.95.1-qttest.patch b/sci-chemistry/avogadro2/files/avogadro2-1.95.1-qttest.patch
new file mode 100644
index 000000000000..ed12da21e3f6
--- /dev/null
+++ b/sci-chemistry/avogadro2/files/avogadro2-1.95.1-qttest.patch
@@ -0,0 +1,15 @@
+diff --git a/avogadro/CMakeLists.txt b/avogadro/CMakeLists.txt
+index d2245ff..fe1857c 100644
+--- a/avogadro/CMakeLists.txt
++++ b/avogadro/CMakeLists.txt
+@@ -80,8 +80,8 @@ endif()
+
+ if(ENABLE_TESTING)
+ find_package(Qt5 COMPONENTS Test REQUIRED)
+- find_package(QtTesting REQUIRED NO_MODULE)
+- include_directories(${QtTesting_INCLUDE_DIRS})
++ find_package(Qt5Test REQUIRED NO_MODULE)
++ include_directories(${Qt5Test_INCLUDE_DIRS})
+ link_directories(${QtTesting_LIBRARY_DIR})
+ add_definitions(-DQTTESTING)
+ endif()