summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/azara/azara-2.8-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/azara/azara-2.8-r4.ebuild')
-rw-r--r--sci-chemistry/azara/azara-2.8-r4.ebuild98
1 files changed, 98 insertions, 0 deletions
diff --git a/sci-chemistry/azara/azara-2.8-r4.ebuild b/sci-chemistry/azara/azara-2.8-r4.ebuild
new file mode 100644
index 000000000000..2b5f3bd6f0b8
--- /dev/null
+++ b/sci-chemistry/azara/azara-2.8-r4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit eutils python toolchain-funcs
+
+DESCRIPTION="A suite of programmes to process and view NMR data"
+HOMEPAGE="http://www.bio.cam.ac.uk/azara/"
+SRC_URI="http://www.bio.cam.ac.uk/ccpn/download/${PN}/${P}-src.tgz"
+
+LICENSE="AZARA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="python xpm X"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/motif:0
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cat > ENVIRONMENT <<- EOF
+ CC=$(tc-getCC)
+ CFLAGS = ${CFLAGS}
+ LFLAGS = ${LDFLAGS}
+ MATH_LIB = -lm
+ X11_INCLUDE_DIR = -I"${EPREFIX}/usr/X11R6/include"
+ MOTIF_INCLUDE_DIR = -I"${EPREFIX}/usr/include" -I../global
+ X11_LIB_DIR = -L"${EPREFIX}/usr/$(get_libdir)"
+ MOTIF_LIB_DIR = -L"${EPREFIX}/usr/$(get_libdir)"
+ X11_LIB = -lX11
+ MOTIF_LIB = -lXm -lXt
+ SHARED_FLAGS = -shared
+ ENDIAN_FLAG = -DBIG_ENDIAN_DATA -DWRITE_ENDIAN_PAR
+ PIC = -fPIC
+ EOF
+
+ use xpm && echo "XPMUSE=\"XPM_FLAG=-DUSE_XPM XPM_LIB=-lXpm\"" >> ENVIRONMENT
+
+ epatch \
+ "${FILESDIR}"/${PV}-prll.patch \
+ "${FILESDIR}"/${PV}-impl-dec.patch \
+ "${FILESDIR}"/${PV}-python.patch \
+ "${FILESDIR}"/${PV}-64bit.patch
+}
+
+src_compile() {
+ local mymake
+ local makeflags
+
+ mymake="${mymake} help nongui"
+ use X && mymake="${mymake} gui"
+
+ emake ${mymake} || die
+
+ compilation() {
+ emake DataRows_clean || die
+ emake \
+ PYTHON_INCLUDE_DIR="-I${EPREFIX}/$(python_get_includedir)" \
+ PYTHON_LIB="$(python_get_library -l)" \
+ DataRows || die
+ }
+ use python && python_execute_function compilation
+}
+
+src_install() {
+ rm bin/pythonAzara || die
+ if ! use X; then
+ rm bin/plot* || die
+ fi
+
+ dodoc CHANGES* README* || die
+ dohtml -r html/* || die
+
+ installation() {
+ insinto $(python_get_sitedir)
+ doins lib/DataRows.so || die
+ }
+ use python && python_execute_function installation
+
+ cd bin
+ dobin ${PN}|| die
+ rm ${PN}
+ for bin in *; do
+ newbin ${bin} ${bin}-${PN} || die "failed to install ${bin}"
+ done
+}
+
+pkg_postinst() {
+ einfo "Due to collision we moved all binary to *-${PN}"
+}