summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/babel/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/babel/files')
-rw-r--r--sci-chemistry/babel/files/10babel1
-rw-r--r--sci-chemistry/babel/files/babel-1.6-gcc32.diff28
-rw-r--r--sci-chemistry/babel/files/babel-1.6-gentoo.diff28
-rw-r--r--sci-chemistry/babel/files/babel-1.6-makefile.patch33
4 files changed, 90 insertions, 0 deletions
diff --git a/sci-chemistry/babel/files/10babel b/sci-chemistry/babel/files/10babel
new file mode 100644
index 000000000000..69f3397638dd
--- /dev/null
+++ b/sci-chemistry/babel/files/10babel
@@ -0,0 +1 @@
+BABEL_DIR=/usr/share/babel
diff --git a/sci-chemistry/babel/files/babel-1.6-gcc32.diff b/sci-chemistry/babel/files/babel-1.6-gcc32.diff
new file mode 100644
index 000000000000..ba0964af5352
--- /dev/null
+++ b/sci-chemistry/babel/files/babel-1.6-gcc32.diff
@@ -0,0 +1,28 @@
+--- block.c.orig Sun Sep 15 04:51:13 2002
++++ block.c Sun Sep 15 04:58:04 2002
+@@ -99,7 +99,12 @@
+ void *array;
+
+ /* calc how much space we are gonna need */
++#ifdef __va_copy
++ __va_copy (ap, initap);
++#else
+ ap = initap;
++#endif
++
+ size = 0;
+ for(i=0; types[i] != '\0'; i++)
+ {
+@@ -116,7 +121,12 @@
+ /* set up the ptrs if we can alloc the memory */
+ if(*handle != NULL)
+ {
++#ifdef __va_copy
++ __va_copy (ap, initap);
++#else
+ ap = initap;
++#endif
++
+ ptr = 0;
+ for(i=0; types[i] != '\0'; i++)
+ {
diff --git a/sci-chemistry/babel/files/babel-1.6-gentoo.diff b/sci-chemistry/babel/files/babel-1.6-gentoo.diff
new file mode 100644
index 000000000000..77e2cb47ef03
--- /dev/null
+++ b/sci-chemistry/babel/files/babel-1.6-gentoo.diff
@@ -0,0 +1,28 @@
+--- Makefile.orig Tue Oct 23 00:20:54 2001
++++ Makefile Tue Oct 23 00:33:36 2001
+@@ -1,11 +1,15 @@
+-CFLAGS = -O
++#Commented out to pull CFLAGS from make.conf
++#CFLAGS = -O
+
+ LIBFLAGS = -O -DLIBRARY
+
+-CC = cc
++#Probably not necessary to specify gcc
++CC = gcc
+
+ PROGRAM = babel
+
++DEST = ${DESTDIR}/$(PROGRAM)
++
+ LDFLAGS =
+
+ LIBS =
+@@ -334,6 +338,7 @@
+ index:; ctags -wx $(HDRS) $(SRCS)
+
+ install: $(PROGRAM)
++ install -d ${DESTDIR}
+ install -s $(PROGRAM) $(DEST)
+
+ print:; $(PRINT) $(HDRS) $(SRCS)
diff --git a/sci-chemistry/babel/files/babel-1.6-makefile.patch b/sci-chemistry/babel/files/babel-1.6-makefile.patch
new file mode 100644
index 000000000000..33b158d1b2cf
--- /dev/null
+++ b/sci-chemistry/babel/files/babel-1.6-makefile.patch
@@ -0,0 +1,33 @@
+diff -Naur babel-1.6/Makefile babel-1.6.new/Makefile
+--- babel-1.6/Makefile 1997-01-21 10:53:05.000000000 -0500
++++ babel-1.6.new/Makefile 2008-10-19 10:41:42.000000000 -0400
+@@ -1,12 +1,16 @@
+-CFLAGS = -O
++#Commented out to pull CFLAGS from make.conf
++#CFLAGS = -O
+
+ LIBFLAGS = -O -DLIBRARY
+
+-CC = cc
++#Probably not necessary to specify gcc
++#CC = gcc
+
+ PROGRAM = babel
+
+-LDFLAGS =
++DEST = ${DESTDIR}/$(PROGRAM)
++
++#LDFLAGS =
+
+ LIBS =
+
+@@ -334,7 +338,8 @@
+ index:; ctags -wx $(HDRS) $(SRCS)
+
+ install: $(PROGRAM)
+- install -s $(PROGRAM) $(DEST)
++ install -d ${DESTDIR}
++ install $(PROGRAM) $(DEST)
+
+ print:; $(PRINT) $(HDRS) $(SRCS)
+