summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-21 11:15:08 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-21 11:25:31 +0100
commit09adb5e6a857d0547a56438c69d31974c447d7af (patch)
treecada1e1eaf41c86277ec0d4de18a0ff7fcbdd5ad /sci-chemistry/cara-bin/cara-bin-1.8.4-r2.ebuild
parentgames-strategy/darwinia-demo: move away from virtual/libstdc++ (diff)
downloadgentoo-09adb5e6a857d0547a56438c69d31974c447d7af.tar.gz
gentoo-09adb5e6a857d0547a56438c69d31974c447d7af.tar.bz2
gentoo-09adb5e6a857d0547a56438c69d31974c447d7af.zip
sci-chemistry/cara-bin: move away from virtual/libstdc++
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sci-chemistry/cara-bin/cara-bin-1.8.4-r2.ebuild')
-rw-r--r--sci-chemistry/cara-bin/cara-bin-1.8.4-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-chemistry/cara-bin/cara-bin-1.8.4-r2.ebuild b/sci-chemistry/cara-bin/cara-bin-1.8.4-r2.ebuild
new file mode 100644
index 000000000000..daba15405832
--- /dev/null
+++ b/sci-chemistry/cara-bin/cara-bin-1.8.4-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN="${PN%%-bin}"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Analysis of NMR spectra and Computer Aided Resonance Assignment"
+SRC_URI="
+ http://www.cara.nmr-software.org/downloads/${MY_P}_linux.gz
+ https://dev.gentoo.org/~jlec/distfiles//Start1.2.cara.xz"
+HOMEPAGE="http://www.nmr.ch"
+
+LICENSE="CARA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="lua"
+
+RDEPEND="
+ !prefix? (
+ >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
+ >=x11-libs/libICE-1.0.8-r1[abi_x86_32(-)]
+ >=x11-libs/libSM-1.2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXcursor-1.1.14[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+ >=x11-libs/libXrandr-1.4.2[abi_x86_32(-)]
+ >=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
+ )
+ sys-libs/libstdc++-v3:5
+ lua? ( dev-lang/lua )"
+DEPEND=""
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/cara/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto /opt/cara
+ doexe ${MY_P}_linux
+ dosym ../cara/${MY_P}_linux /opt/bin/cara
+ dodoc Start1.2.cara
+}