summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-02-12 18:55:54 +0000
committerJustin Lecher <jlec@gentoo.org>2017-02-12 19:08:42 +0000
commite9b522a3b065fa8ce8e376a918ba257141b862ab (patch)
tree577304b21dce9e20539bce5bbbe07f39db91c238 /sci-chemistry/chemical-mime-data
parentsys-apps/fakeroot: Backport patch for glibc-2.24 (diff)
downloadgentoo-e9b522a3b065fa8ce8e376a918ba257141b862ab.tar.gz
gentoo-e9b522a3b065fa8ce8e376a918ba257141b862ab.tar.bz2
gentoo-e9b522a3b065fa8ce8e376a918ba257141b862ab.zip
sci-chemistry/chemical-mime-data: Add back support for rsvg from gnome-base/librsvg
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/chemical-mime-data')
-rw-r--r--sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r3.ebuild8
-rw-r--r--sci-chemistry/chemical-mime-data/files/chemical-mime-data-0.1.94-rsvg-convert.patch30
2 files changed, 36 insertions, 2 deletions
diff --git a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r3.ebuild b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r3.ebuild
index 5b8fc00d5b7f..a1204870849c 100644
--- a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r3.ebuild
+++ b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,13 +22,17 @@ DEPEND="${RDEPEND}
dev-util/intltool
dev-util/desktop-file-utils
dev-libs/libxslt
- media-gfx/imagemagick[xml,png,svg]
+ || (
+ gnome-base/librsvg[tools]
+ media-gfx/imagemagick[xml,png,svg]
+ )
virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-turbomole.patch
"${FILESDIR}"/${P}-pigz.patch
"${FILESDIR}"/${P}-namespace-svg.patch
+ "${FILESDIR}"/${P}-rsvg-convert.patch
)
src_prepare() {
diff --git a/sci-chemistry/chemical-mime-data/files/chemical-mime-data-0.1.94-rsvg-convert.patch b/sci-chemistry/chemical-mime-data/files/chemical-mime-data-0.1.94-rsvg-convert.patch
new file mode 100644
index 000000000000..8a92e19e1578
--- /dev/null
+++ b/sci-chemistry/chemical-mime-data/files/chemical-mime-data-0.1.94-rsvg-convert.patch
@@ -0,0 +1,30 @@
+ configure.ac | 2 +-
+ icons/hicolor/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6f87a94..a503da4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -102,7 +102,7 @@ if test "x$enable_convert" != "xyes" -a "x$CONVERT" = "xno" ; then
+ [RSVG],
+ [The 'rsvg' binary with path. Use it to define or override the location of 'rsvg'.]
+ )
+- AC_PATH_PROG([RSVG], [rsvg], [no])
++ AC_PATH_PROG([RSVG], [rsvg-convert], [no])
+ AC_SUBST([RSVG])
+ fi
+
+diff --git a/icons/hicolor/Makefile.am b/icons/hicolor/Makefile.am
+index ba0847a..f2e0a84 100644
+--- a/icons/hicolor/Makefile.am
++++ b/icons/hicolor/Makefile.am
+@@ -24,7 +24,7 @@ if BOOL_HICOLOR_THEME
+ gzip -c $< > $@
+ for size in $(icon_sizes) ; do \
+ if test "x$(RSVG)" != "x" ; then \
+- $(RSVG) -w $${size} -h $${size} -f png $< $*_$${size}.png ; \
++ $(RSVG) -w $${size} -h $${size} -f png $< --output $*_$${size}.png ; \
+ else \
+ $(CONVERT) $< -resize $${size}x$${size} $*_$${size}.png ; \
+ fi \