summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/chemtool/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/chemtool/files')
-rw-r--r--sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch b/sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch
new file mode 100644
index 000000000000..5d2fe36d6bf1
--- /dev/null
+++ b/sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch
@@ -0,0 +1,78 @@
+ Makefile.am | 6 ++++--
+ configure.ac | 24 ++++--------------------
+ 2 files changed, 8 insertions(+), 22 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 99dbf8c..931ba16 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,10 +22,12 @@ localedir = $(datadir)/locale
+ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
+ # Make sure the gettext.h include file is found.
+-AM_CPPFLAGS = -I. -I$(srcdir) @GTK_CFLAGS@
++AM_CPPFLAGS = -I. -I$(srcdir) @GTK_CFLAGS@ @EMFINCL@
+
+ # Link time dependencies.
+-LDADD = @LIBINTL@ @GTK_LIBS@ @EMFLIBS@
++LDADD = @LIBINTL@ @GTK_LIBS@ @EMFLIBS@ -lX11
++
++AM_CFLAGS = -DGTK2
+
+ # Additional files to be distributed.
+ EXTRA_DIST = autogen.sh autoclean.sh
+diff --git a/configure.ac b/configure.ac
+index 6d8c45a..c5fab42 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,32 +32,14 @@ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+
+ AC_MSG_CHECKING([for GTK version and compile options ])
+
+-if test x$PKG_CONFIG = xno -o x$enable_gtk1 = xyes ; then
+-AM_PATH_GTK(1.0.2, , exit 1)
+-else
+-if $PKG_CONFIG gtk+-2.0 --cflags ; then
+- GTK_CFLAGS="-DGTK2 `$PKG_CONFIG gtk+-2.0 --cflags` "
+- GTK_LIBS=`$PKG_CONFIG gtk+-2.0 --libs`
+-dnl use_gtk2=yes
+- AC_DEFINE([GTK2], [1], [the GTK2 library])
+- enable_stockgtk=yes
+-else
+-if $PKG_CONFIG --cflags gtk+ ; then
+- GTK_CFLAGS=`$PKG_CONFIG gtk+ --cflags`
+- GTK_LIBS=`$PKG_CONFIG gtk+ --libs`
+-dnl use_gtk2=no
+-fi
+-fi
+-fi
+-
+-dnl AC_MSG_RESULT using GTK2 : $use_gtk2
++PKG_CHECK_MODULES([GTK],[gtk+-2.0])
+
+ dnl Checks for header files.
+ AC_PATH_XTRA
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
+
+-LDFLAGS="$X_LIBS"
++LDFLAGS+="$X_LIBS"
+ AC_CHECK_LIB([X11],[XOpenDisplay])
+ dnl just an ugly hack to work around the more aggressive header checks
+ dnl in recent autoconf. Not sure if we should really rely on include
+@@ -184,6 +166,7 @@ if test x$enable_emf = xyes; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([EMF], [1], [use optional libEMF instead of fig2dev for EMF output])
+ EMFLIBS="-lEMF -lstdc++"
++ EMFINCL="-I${includedir}libEMF"
+ else
+ AC_MSG_RESULT(no)
+ EMFLIBS=""
+@@ -221,6 +204,7 @@ AC_SUBST(localedir)
+ AC_SUBST(kdemimedir)
+ AC_SUBST(gnomemimedir)
+ AC_SUBST(EMFLIBS)
++AC_SUBST(EMFINCL)
+ AC_SUBST(MYGTKSRCS)
+ AC_SUBST(MYGTKOBJS)
+ AC_SUBST(GTK_CFLAGS)