summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-02 13:59:21 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-02 14:00:49 +0200
commit4e4e045da2570733e3a7cf50ed1712945d44dc2f (patch)
treef8aaf92e813a75be4ed184c93baba6a8165bf25f /sci-chemistry/dssp/dssp-3.0.11.ebuild
parentsci-chemistry/dssp: Needs boost with zlib and bzip2 support (diff)
downloadgentoo-4e4e045da2570733e3a7cf50ed1712945d44dc2f.tar.gz
gentoo-4e4e045da2570733e3a7cf50ed1712945d44dc2f.tar.bz2
gentoo-4e4e045da2570733e3a7cf50ed1712945d44dc2f.zip
sci-chemistry/dssp: Bump to 3.0.11
It is the latest version that seems to work with gmx do_dssp from my tests, also the one packaged in Fedora currently Closes: https://bugs.gentoo.org/802417 Closes: https://bugs.gentoo.org/808669 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry/dssp/dssp-3.0.11.ebuild')
-rw-r--r--sci-chemistry/dssp/dssp-3.0.11.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/dssp-3.0.11.ebuild b/sci-chemistry/dssp/dssp-3.0.11.ebuild
new file mode 100644
index 000000000000..b0771e31047d
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-3.0.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+MY_PN="hssp"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/cmbi/hssp"
+SRC_URI="https://github.com/cmbi/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl:=
+ dev-libs/boost:=[bzip2,zlib,threads(+)]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Fix version
+ sed -i -e "s/3.0.10/${PV}/" configure.ac || die
+
+ sed -i -e '/-Werror/d' Makefile.am || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ dosym mkdssp /usr/bin/dssp
+ doenvd "${FILESDIR}"/30-${PN}
+}