summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-10-03 20:45:40 +0200
committerPacho Ramos <pacho@gentoo.org>2021-10-03 20:45:40 +0200
commit3ae2f860fb5615e5618a6c4ebc3da0a4e49f63b1 (patch)
tree9449fba69242b4f343d45224fbe1f4a776d0d432 /sci-chemistry/dssp/dssp-4.0.3.ebuild
parentsci-libs/libcifpp: Bump to 2.0.0 (diff)
downloadgentoo-3ae2f860fb5615e5618a6c4ebc3da0a4e49f63b1.tar.gz
gentoo-3ae2f860fb5615e5618a6c4ebc3da0a4e49f63b1.tar.bz2
gentoo-3ae2f860fb5615e5618a6c4ebc3da0a4e49f63b1.zip
sci-chemistry/dssp: Bump to 4.0.3
Package-Manager: Portage-3.0.24, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry/dssp/dssp-4.0.3.ebuild')
-rw-r--r--sci-chemistry/dssp/dssp-4.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/dssp-4.0.3.ebuild b/sci-chemistry/dssp/dssp-4.0.3.ebuild
new file mode 100644
index 000000000000..d9d8a5740c8d
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-4.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/PDB-REDO/dssp"
+
+SRC_URI="https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+ >=dev-libs/boost-1.70.0:=[zlib,threads(+)]
+ >=sci-libs/libcifpp-2.0.0
+"
+DEPEND=""
+RDEPEND="${BDEPEND}"
+
+pkg_postinst() {
+ if has_version sci-chemistry/gromacs; then
+ ewarn "DSSP > 3.0.x is not compatible with gmx do_dssp:"
+ ewarn "https://gitlab.com/gromacs/gromacs/-/issues/4129"
+ ewarn
+ ewarn "Feel free to mask newer versions if needed."
+ fi
+}