summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/eden/files/5.3-makefile-fixes.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/eden/files/5.3-makefile-fixes.patch')
-rw-r--r--sci-chemistry/eden/files/5.3-makefile-fixes.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/eden/files/5.3-makefile-fixes.patch b/sci-chemistry/eden/files/5.3-makefile-fixes.patch
new file mode 100644
index 000000000000..632358341784
--- /dev/null
+++ b/sci-chemistry/eden/files/5.3-makefile-fixes.patch
@@ -0,0 +1,60 @@
+ source/Makefile | 17 ++++++++++-------
+ 1 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/source/Makefile b/source/Makefile
+index 46d89cc..aa751c7 100644
+--- a/source/Makefile
++++ b/source/Makefile
+@@ -78,8 +78,10 @@ CFLAGS = -Wall -pipe -g3
+ #CFLAGS = -Wall -pipe -marchi686 -pedantic -gdwarf-2 -g3
+ #CFLAGS = -Wall -O3 -march=i686
+ ifneq ($(FFTW),/usr/local)
++ifneq ($(FFTW),/usr)
+ CFLAGS += -I$(INC)
+ endif
++endif
+
+ # NOTE:
+ # DOUBLESWITCH = ON for double precision;
+@@ -91,15 +93,15 @@ endif
+ DOUBLESWITCH = ON
+
+ ifeq ($(DOUBLESWITCH),ON)
+-LDFLAGS = -L$(LIB) -ldfftw -lm
++LIBS = -L$(LIB) -ldfftw -lm
+ CFLAGS += -DDOUBLE
+ TARGET = deden
+ else
+-LDFLAGS = -L$(LIB) -lsfftw -lm
++LIBS = -L$(LIB) -lsfftw -lm
+ TARGET = seden
+ endif
+
+-LDFLAGS += -g -lgsl -lgslcblas
++LIBS += -lgsl -lgslcblas
+
+ # GSL_PREFIX:= /sw/lib
+ # LDFLAGS += -l$(GSL_PREFIX)/libgsl.a -l$(GSL_PREFIX)/libgslcblas.a
+@@ -120,17 +122,18 @@ OBJ = addmaps.o apodfc.o apodfo.o back.o cadhkl.o \
+ all: eden fbyteswap
+
+ eden: eden.o $(OBJ)
+- $(CC) $^ $(LDFLAGS) -o $@
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ fbyteswap: fbyteswap.c
+- $(CC) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ install: all
++ mkdir -p $(BIN)
+ mv fbyteswap $(BIN)
+ mv eden $(BIN)/$(TARGET)
+ chmod 751 $(BIN)/$(TARGET)
+- chmod +x mkeden.csh
+- ./mkeden.csh $(BIN) $(BIN)/$(TARGET)
++# chmod +x mkeden.csh
++# ./mkeden.csh $(BIN) $(BIN)/$(TARGET)
+
+ dist: clean
+ cd ../..; tar -cvf eden_$(VERSION).tar --exclude CVS --exclude \#\*\# --exclude \*~ --exclude Misc --exclude .\* eden; gzip -f eden_$(VERSION).tar