summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild')
-rw-r--r--sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild b/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..78bfcff23630
--- /dev/null
+++ b/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils fdo-mime gnome2-utils eutils
+
+DESCRIPTION="Periodic table viewer that provides detailed information on the chemical elements"
+HOMEPAGE="http://freecode.com/projects/gelemental/"
+SRC_URI="
+ http://www.kdau.com/files/${P}.tar.bz2
+ mirror://debian/pool/main/g/${PN}/${PN}_${PV}-8.debian.tar.gz"
+
+LICENSE="GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-cpp/gtkmm:2.4
+ dev-cpp/glibmm:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ dev-util/intltool
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc4.3.patch
+ "${FILESDIR}"/${P}-glib-2.32.patch
+ "${FILESDIR}"/${P}-doxygen.patch
+ "${WORKDIR}"/debian/patches/579183_adjust_size_middle_button.patch
+ "${WORKDIR}"/debian/patches/604612_fix_menu_category.patch
+ "${WORKDIR}"/debian/patches/604618_scrollable_properties_dialog.patch
+ "${WORKDIR}"/debian/patches/656372_element_renames.patch
+ "${WORKDIR}"/debian/patches/add_new_wave_theme.patch
+ "${WORKDIR}"/debian/patches/czech_translation_559028.patch
+ "${WORKDIR}"/debian/patches/fix_gtkmm_2.18.patch
+ "${WORKDIR}"/debian/patches/fix_zinc_german_translation.patch
+ "${WORKDIR}"/debian/patches/ftbfs_missing_limits.patch
+ "${WORKDIR}"/debian/patches/lp673285_link_in_about.patch
+ )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=( $(use_enable doc api-docs) )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install apidir="/usr/share/doc/${PF}/html"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}