summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-04-24 08:27:34 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-04-24 08:28:10 -0500
commit18ea2dae1d58e86addb1a3e8960b4c501d5135e6 (patch)
tree03b8ee4e670cf49bccb5ea404b8d44370ad0609b /sci-chemistry/gelemental/gelemental-2.0.1.ebuild
parentdev-java/tomcat-native: Stabilize 1.2.32 amd64, #840574 (diff)
downloadgentoo-18ea2dae1d58e86addb1a3e8960b4c501d5135e6.tar.gz
gentoo-18ea2dae1d58e86addb1a3e8960b4c501d5135e6.tar.bz2
gentoo-18ea2dae1d58e86addb1a3e8960b4c501d5135e6.zip
sci-chemistry/gelemental: add 2.0.1
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-chemistry/gelemental/gelemental-2.0.1.ebuild')
-rw-r--r--sci-chemistry/gelemental/gelemental-2.0.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-chemistry/gelemental/gelemental-2.0.1.ebuild b/sci-chemistry/gelemental/gelemental-2.0.1.ebuild
new file mode 100644
index 000000000000..d74be9286d1e
--- /dev/null
+++ b/sci-chemistry/gelemental/gelemental-2.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic xdg
+
+DESCRIPTION="Periodic table viewer with detailed information on the chemical elements"
+HOMEPAGE="https://github.com/ginggs/gelemental/"
+SRC_URI="https://github.com/ginggs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-cpp/gtkmm:2.4
+ dev-cpp/glibmm:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pango.patch
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11 #566450
+
+ econf \
+ --disable-static \
+ $(use_enable doc api-docs)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}