summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/gperiodic/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/gperiodic/files')
-rw-r--r--sci-chemistry/gperiodic/files/gperiodic-2.0.10-makefile.patch64
-rw-r--r--sci-chemistry/gperiodic/files/gperiodic-2.0.10-nls.patch20
2 files changed, 84 insertions, 0 deletions
diff --git a/sci-chemistry/gperiodic/files/gperiodic-2.0.10-makefile.patch b/sci-chemistry/gperiodic/files/gperiodic-2.0.10-makefile.patch
new file mode 100644
index 000000000000..abdb5caae4f2
--- /dev/null
+++ b/sci-chemistry/gperiodic/files/gperiodic-2.0.10-makefile.patch
@@ -0,0 +1,64 @@
+Respect CC, CFLAGS, LDFLAGS
+Fix install paths
+Fix parallel build
+Drop DEPRECATED flags, bug #391099
+
+--- Makefile
++++ Makefile
+@@ -1,6 +1,5 @@
+-CC := gcc
+-CFLAGS := `pkg-config --cflags gtk+-2.0` -I. -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED
+-LIBS :=`pkg-config --libs gtk+-2.0`
++CFLAGS += `pkg-config --cflags gtk+-2.0` -I.
++LIBS +=`pkg-config --libs gtk+-2.0`
+ bindir ?= /usr/bin
+ datadir ?= /usr/share
+ enable_nls ?= 1
+@@ -8,12 +7,11 @@
+ .c.o:
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) $<
+
+-all:
+- make gperiodic
+- make -C po/ all enable_nls=$(enable_nls)
++all: gperiodic
++ $(MAKE) -C po/ all enable_nls=$(enable_nls)
+
+ gperiodic: gperiodic.o
+- $(CC) $(CFLAGS) -o gperiodic gperiodic.o $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o gperiodic gperiodic.o $(LIBS)
+ ifeq ($(strip),1)
+ strip gperiodic
+ endif
+@@ -23,24 +21,21 @@
+ gperiodic.o: gperiodic.c gperiodic.h table_data.h
+
+ install:
+- mkdir -p $(DESTDIR)$(bindir)
+- install -m 755 gperiodic $(DESTDIR)$(bindir)
+- mkdir -p $(DESTDIR)$(datadir)/applications
+- install -m 644 gperiodic.desktop $(DESTDIR)$(datadir)/applications
+- mkdir -p $(DESTDIR)$(datadir)/pixmaps
+- install -m 644 gperiodic.png $(DESTDIR)$(datadir)/pixmaps
+- install -m 644 gperiodic-crystal.png $(DESTDIR)$(datadir)/pixmaps
+- make -C po/ install enable_nls=$(enable_nls) datadir=$(datadir) DESTDIR=$(DESTDIR)
++ install -D -m 755 gperiodic $(DESTDIR)$(bindir)/gperiodic
++ install -D -m 644 gperiodic.desktop $(DESTDIR)$(datadir)/applications/gperiodic.desktop
++ install -D -m 644 gperiodic.png $(DESTDIR)$(datadir)/pixmaps/gperiodic.png
++ install -m 644 gperiodic-crystal.png $(DESTDIR)$(datadir)/pixmaps/gperiodic-crystal.png
++ $(MAKE) -C po/ install enable_nls=$(enable_nls) datadir=$(datadir) DESTDIR=$(DESTDIR)
+
+ uninstall:
+ rm -f $(bindir)/gperiodic \
+ $(datadir)/applications/gperiodic.desktop
+ $(datadir)/pixmaps/gperiodic.png \
+ $(datadir)/pixmaps/gperiodic-crystal.png
+- make -C po/ uninstall enable_nls=$(enable_nls) datadir=$(datadir) DESTDIR=$(DESTDIR)
++ $(MAKE) -C po/ uninstall enable_nls=$(enable_nls) datadir=$(datadir) DESTDIR=$(DESTDIR)
+
+ clean:
+ rm -f *.o gperiodic
+- make -C po/ clean
++ $(MAKE) -C po/ clean
+
+ .PHONY: install uninstall clean
diff --git a/sci-chemistry/gperiodic/files/gperiodic-2.0.10-nls.patch b/sci-chemistry/gperiodic/files/gperiodic-2.0.10-nls.patch
new file mode 100644
index 000000000000..de0bea04dc14
--- /dev/null
+++ b/sci-chemistry/gperiodic/files/gperiodic-2.0.10-nls.patch
@@ -0,0 +1,20 @@
+ po/Makefile | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/po/Makefile b/po/Makefile
+index d7d7d78..179dad6 100644
+--- a/po/Makefile
++++ b/po/Makefile
+@@ -26,10 +26,12 @@ endif
+
+ install:
+ $(MAKE) all
++ifeq ($(enable_nls),1)
+ for f in $(FILES_MO) ; do \
+ mkdir -p $(DESTDIR)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES ; \
+ install -m 644 $$f $(DESTDIR)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES/$(PACKAGE).mo ; \
+ done
++endif
+
+ uninstall:
+ for f in $(FILES_MO) ; do \