summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-02-21 19:33:29 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-02-21 19:36:36 +0300
commit3be10d9efadf209bd58dc917671b4584c49824a6 (patch)
tree78c1a74b16d3335671c85a3a66daff32d1b7de85 /sci-chemistry/gromacs
parentsci-chemistry/gromacs: Fix musl build (missing int64_t) for 2022 (diff)
downloadgentoo-3be10d9efadf209bd58dc917671b4584c49824a6.tar.gz
gentoo-3be10d9efadf209bd58dc917671b4584c49824a6.tar.bz2
gentoo-3be10d9efadf209bd58dc917671b4584c49824a6.zip
sci-chemistry/gromacs: Fix build for musl
Closes: https://bugs.gentoo.org/828673 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/files/gromacs-2021-musl-stdint.patch25
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild2
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.5.ebuild2
3 files changed, 29 insertions, 0 deletions
diff --git a/sci-chemistry/gromacs/files/gromacs-2021-musl-stdint.patch b/sci-chemistry/gromacs/files/gromacs-2021-musl-stdint.patch
new file mode 100644
index 000000000000..c94fc5598f91
--- /dev/null
+++ b/sci-chemistry/gromacs/files/gromacs-2021-musl-stdint.patch
@@ -0,0 +1,25 @@
+From 8a38303c52fbca07c850e0c4cd03a783aabf9e49 Mon Sep 17 00:00:00 2001
+From: Paul Bauer <paul.bauer.q@gmail.com>
+Date: Mon, 21 Feb 2022 09:53:46 +0100
+Subject: [PATCH] Fix missing includes for musl libc
+
+Fixes #4404
+---
+ src/gromacs/math/vectypes.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/gromacs/math/vectypes.h b/src/gromacs/math/vectypes.h
+index d4d5211d11..bd9d31de20 100644
+--- a/src/gromacs/math/vectypes.h
++++ b/src/gromacs/math/vectypes.h
+@@ -40,6 +40,7 @@
+
+ #include <cassert>
+ #include <cmath>
++#include <cstdint>
+
+ #include <algorithm>
+ #include <type_traits>
+--
+2.35.1
+
diff --git a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
index 304523f0caed..9ebdeb01146c 100644
--- a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
@@ -83,6 +83,8 @@ DOCS=( AUTHORS README )
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${PN}-2021-musl-stdint.patch" )
+
if [[ ${PV} != *9999 ]]; then
S="${WORKDIR}/${PN}-${PV/_/-}"
fi
diff --git a/sci-chemistry/gromacs/gromacs-2021.5.ebuild b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
index d9c7e8a5269e..abf5ed8ec5ef 100644
--- a/sci-chemistry/gromacs/gromacs-2021.5.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
@@ -83,6 +83,8 @@ DOCS=( AUTHORS README )
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${PN}-2021-musl-stdint.patch" )
+
if [[ ${PV} != *9999 ]]; then
S="${WORKDIR}/${PN}-${PV/_/-}"
fi