summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-12-21 00:05:40 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-12-21 00:06:08 +0300
commit478021fb91ad87a334fe29a1fc584bef7e7e6566 (patch)
tree4c564604334a72ac061c56595b87e408d3b1cab8 /sci-chemistry/gromacs
parentdev-libs/bcm2835: add 1.71 (diff)
downloadgentoo-478021fb91ad87a334fe29a1fc584bef7e7e6566.tar.gz
gentoo-478021fb91ad87a334fe29a1fc584bef7e7e6566.tar.bz2
gentoo-478021fb91ad87a334fe29a1fc584bef7e7e6566.zip
sci-chemistry/gromacs: remove mkl-10 hack
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.7.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.5.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.6.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.9999.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.3.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.4.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.9999.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2023.9999.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2023_rc1.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild5
15 files changed, 0 insertions, 75 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild b/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
index a26f3ea46d56..8933f1086eac 100644
--- a/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
@@ -106,11 +106,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
index 1a1a44ea6d18..7999d7a192fd 100644
--- a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
@@ -109,11 +109,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild b/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
index a81288076d3a..991c92890086 100644
--- a/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
@@ -111,11 +111,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild b/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
index 1b2e86c8a65f..78df12fce7b2 100644
--- a/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
@@ -181,11 +181,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2020.7.ebuild b/sci-chemistry/gromacs/gromacs-2020.7.ebuild
index 9af3d2969914..30ae2a339b00 100644
--- a/sci-chemistry/gromacs/gromacs-2020.7.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.7.ebuild
@@ -181,11 +181,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
index e114ec2e9524..af9a28c8f506 100644
--- a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
@@ -189,11 +189,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2021.5.ebuild b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
index 3b0c96dab99d..81c13a98d102 100644
--- a/sci-chemistry/gromacs/gromacs-2021.5.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
@@ -189,11 +189,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2021.6.ebuild b/sci-chemistry/gromacs/gromacs-2021.6.ebuild
index 3b0c96dab99d..81c13a98d102 100644
--- a/sci-chemistry/gromacs/gromacs-2021.6.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.6.ebuild
@@ -189,11 +189,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
index fca4a085908b..359c6291595c 100644
--- a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
@@ -187,11 +187,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2022.3.ebuild b/sci-chemistry/gromacs/gromacs-2022.3.ebuild
index b5227c43c97f..45c3e54bce9c 100644
--- a/sci-chemistry/gromacs/gromacs-2022.3.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.3.ebuild
@@ -200,11 +200,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2022.4.ebuild b/sci-chemistry/gromacs/gromacs-2022.4.ebuild
index b5227c43c97f..45c3e54bce9c 100644
--- a/sci-chemistry/gromacs/gromacs-2022.4.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.4.ebuild
@@ -200,11 +200,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2022.9999.ebuild b/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
index b5227c43c97f..45c3e54bce9c 100644
--- a/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
@@ -200,11 +200,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2023.9999.ebuild b/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
index 3d7e9b7a194d..b20d89c5266a 100644
--- a/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
@@ -199,11 +199,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-2023_rc1.ebuild b/sci-chemistry/gromacs/gromacs-2023_rc1.ebuild
index 3d7e9b7a194d..b20d89c5266a 100644
--- a/sci-chemistry/gromacs/gromacs-2023_rc1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2023_rc1.ebuild
@@ -199,11 +199,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index 3d7e9b7a194d..b20d89c5266a 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -199,11 +199,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl