summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-12-20 21:23:24 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-12-20 21:24:57 +0300
commit47b82f89a877ec68759c5a488473875e8184cc1a (patch)
tree95daf53e58796de2618032cbf5dde09391580910 /sci-chemistry/gromacs
parentsci-chemistry/gromacs: Add 2022.4 and fix pep517 (diff)
downloadgentoo-47b82f89a877ec68759c5a488473875e8184cc1a.tar.gz
gentoo-47b82f89a877ec68759c5a488473875e8184cc1a.tar.bz2
gentoo-47b82f89a877ec68759c5a488473875e8184cc1a.zip
sci-chemistry/gromacs: Fix pep517
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild3
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.7.ebuild3
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild3
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.5.ebuild3
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.6.ebuild3
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.9999.ebuild3
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild3
7 files changed, 14 insertions, 7 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild b/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
index 178926f0014d..90ca3b46ae0a 100644
--- a/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
@@ -7,7 +7,8 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=no
DISTUTILS_SINGLE_IMPL=1
inherit bash-completion-r1 cmake cuda distutils-r1 flag-o-matic readme.gentoo-r1 toolchain-funcs xdg-utils
diff --git a/sci-chemistry/gromacs/gromacs-2020.7.ebuild b/sci-chemistry/gromacs/gromacs-2020.7.ebuild
index de3335b0e75c..ef73982121ff 100644
--- a/sci-chemistry/gromacs/gromacs-2020.7.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.7.ebuild
@@ -7,7 +7,8 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=no
DISTUTILS_SINGLE_IMPL=1
inherit bash-completion-r1 cmake cuda distutils-r1 flag-o-matic readme.gentoo-r1 toolchain-funcs xdg-utils
diff --git a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
index 68d9a92c288d..c8f88acab2c3 100644
--- a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
@@ -7,7 +7,8 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=no
DISTUTILS_SINGLE_IMPL=1
inherit bash-completion-r1 cmake cuda distutils-r1 flag-o-matic readme.gentoo-r1 toolchain-funcs xdg-utils
diff --git a/sci-chemistry/gromacs/gromacs-2021.5.ebuild b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
index 2f7f4f77115a..c3df9c15d1d4 100644
--- a/sci-chemistry/gromacs/gromacs-2021.5.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
@@ -7,7 +7,8 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=no
DISTUTILS_SINGLE_IMPL=1
inherit bash-completion-r1 cmake cuda distutils-r1 flag-o-matic readme.gentoo-r1 toolchain-funcs xdg-utils
diff --git a/sci-chemistry/gromacs/gromacs-2021.6.ebuild b/sci-chemistry/gromacs/gromacs-2021.6.ebuild
index 2f7f4f77115a..c3df9c15d1d4 100644
--- a/sci-chemistry/gromacs/gromacs-2021.6.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.6.ebuild
@@ -7,7 +7,8 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=no
DISTUTILS_SINGLE_IMPL=1
inherit bash-completion-r1 cmake cuda distutils-r1 flag-o-matic readme.gentoo-r1 toolchain-funcs xdg-utils
diff --git a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
index af0fa65d05eb..44a39087816b 100644
--- a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
@@ -7,7 +7,8 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=no
DISTUTILS_SINGLE_IMPL=1
inherit bash-completion-r1 cmake cuda distutils-r1 flag-o-matic readme.gentoo-r1 toolchain-funcs xdg-utils
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index 2b70114b7ade..f8165b39b590 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -7,7 +7,8 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=no
DISTUTILS_SINGLE_IMPL=1
inherit bash-completion-r1 cmake cuda distutils-r1 flag-o-matic readme.gentoo-r1 toolchain-funcs xdg-utils