summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-28 15:14:48 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-28 15:15:02 +0100
commit42c276a1602f6ddf7f1725e7b81115a1aa4ecc0e (patch)
treebd88aee0da80876b18bf44f1f51f0b10e7e25184 /sci-chemistry/mdtraj
parentsci-chemistry/MDAnalysis: add version 2.0.0, enable py3.10 (diff)
downloadgentoo-42c276a1602f6ddf7f1725e7b81115a1aa4ecc0e.tar.gz
gentoo-42c276a1602f6ddf7f1725e7b81115a1aa4ecc0e.tar.bz2
gentoo-42c276a1602f6ddf7f1725e7b81115a1aa4ecc0e.zip
sci-chemistry/mdtraj: add version 1.9.7, enable py3.10, fix tests
Bug: https://bugs.gentoo.org/809770 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-chemistry/mdtraj')
-rw-r--r--sci-chemistry/mdtraj/Manifest1
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/mdtraj/Manifest b/sci-chemistry/mdtraj/Manifest
index 369fb48765ab..353f6958a591 100644
--- a/sci-chemistry/mdtraj/Manifest
+++ b/sci-chemistry/mdtraj/Manifest
@@ -1 +1,2 @@
DIST mdtraj-1.9.4.tar.gz 2133297 BLAKE2B c1507246bf0c8d7f6753f3d505f940e6f2f001361e42f10c9775647a7e6b58edf2d3953a8e48932f6bf9ad90b27e1baf30df6a7c1a590e49a860175822a25360 SHA512 55f67546db20ce63da3af2231df459e9983e15a65da960784613f746dcce820fe6b0deffbb21b528e93fc6cf674dc7a25ee11110894d2a89e5504e20d200ca38
+DIST mdtraj-1.9.7.tar.gz 2087085 BLAKE2B 430b42eddee0be8beba47994efd16515727970ac7acb36007c9b153cdb474551e5ea228f78a194fa9672d5b169753a9db3c090412bf749b3f1e9323bad9f52de SHA512 5dc9d474909a160e0b1d7989325e8190d1c593087f0130854094eb9c49bc00fd631ea19142d396d49aa7a3dadddaf535b5e811f7574ffff36f0cd22f14691067
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
new file mode 100644
index 000000000000..b069f9456270
--- /dev/null
+++ b/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read, write and analyze MD trajectories with only a few lines of Python code"
+HOMEPAGE="http://mdtraj.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/astunparse[${PYTHON_USEDEP}]
+ dev-python/astor[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
+ -i basesetup.py || die
+ distutils-r1_python_prepare_all
+}