summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/mead/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/mead/files')
-rw-r--r--sci-chemistry/mead/files/mead-2.2.7-gcc43.patch22
-rw-r--r--sci-chemistry/mead/files/mead-2.2.7-respect-cflags.patch57
-rw-r--r--sci-chemistry/mead/files/mead-2.2.7-respect-flags.patch74
3 files changed, 153 insertions, 0 deletions
diff --git a/sci-chemistry/mead/files/mead-2.2.7-gcc43.patch b/sci-chemistry/mead/files/mead-2.2.7-gcc43.patch
new file mode 100644
index 000000000000..673f25890e74
--- /dev/null
+++ b/sci-chemistry/mead/files/mead-2.2.7-gcc43.patch
@@ -0,0 +1,22 @@
+--- mead-2.2.7.orig/libmead/AtomSet.h
++++ mead-2.2.7/libmead/AtomSet.h
+@@ -31,8 +31,7 @@
+
+ #include <map>
+ #include <list>
+-#include <string>
+-using std::string;
++#include <string.h>
+ #include "MEAD/Atom.h"
+ #include "MEAD/Coord.h"
+ #include "MEAD/AtomID.h"
+--- mead-2.2.7.orig/libmead/DielCubeRep.h
++++ mead-2.2.7/libmead/DielCubeRep.h
+@@ -31,6 +31,7 @@
+
+ #include "MEAD/CubeLatSpec.h"
+ #include "MEAD/globals.h"
++#include <string.h>
+
+ class DielCubeRep {
+ public:
diff --git a/sci-chemistry/mead/files/mead-2.2.7-respect-cflags.patch b/sci-chemistry/mead/files/mead-2.2.7-respect-cflags.patch
new file mode 100644
index 000000000000..61c54737778e
--- /dev/null
+++ b/sci-chemistry/mead/files/mead-2.2.7-respect-cflags.patch
@@ -0,0 +1,57 @@
+diff -Naur mead-2.2.7-orig/apps/libmso/Makefile.in mead-2.2.7/apps/libmso/Makefile.in
+--- mead-2.2.7-orig/apps/libmso/Makefile.in 2004-12-10 14:33:49.000000000 -0600
++++ mead-2.2.7/apps/libmso/Makefile.in 2009-02-15 16:32:40.000000000 -0600
+@@ -35,8 +35,8 @@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+
+ ALL_CPPFLAGS = -I. $(LOCALINCS) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
+-ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS)
+-ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
++ALL_CXXFLAGS = @CXXFLAGS@
++ALL_CFLAGS = @CFLAGS@
+
+ .SUFFIXES:
+ .SUFFIXES: .cc .o
+diff -Naur mead-2.2.7-orig/apps/Makefile.common.in mead-2.2.7/apps/Makefile.common.in
+--- mead-2.2.7-orig/apps/Makefile.common.in 2004-11-19 16:49:56.000000000 -0600
++++ mead-2.2.7/apps/Makefile.common.in 2009-02-15 16:32:22.000000000 -0600
+@@ -36,10 +36,10 @@
+ LIBS = @LIBS@ -lm
+
+ ALL_CPPFLAGS = -I. $(LOCALINCS) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
+-ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS)
+-ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
++ALL_CXXFLAGS = @CXXFLAGS@
++ALL_CFLAGS = @CFLAGS@
+
+-CXXLINK = $(CXX) $(ALL_CPPFLAGS) $(CXX_DEBUGFLAGS) $(CXX_OPTFLAGS) \
++CXXLINK = $(CXX) $(ALL_CPPFLAGS) @CXXFLAGS@ \
+ $(LDFLAGS)
+
+ .SUFFIXES: .cc .o
+diff -Naur mead-2.2.7-orig/libmead/Makefile.in mead-2.2.7/libmead/Makefile.in
+--- mead-2.2.7-orig/libmead/Makefile.in 2008-03-04 14:18:22.000000000 -0600
++++ mead-2.2.7/libmead/Makefile.in 2009-02-15 16:31:56.000000000 -0600
+@@ -99,8 +99,8 @@
+ INCLUDES = -I$(top_srcdir)
+
+ ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
+-ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS) $(CXX_SHAREDFLAGS)
+-ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
++ALL_CXXFLAGS = @CXXFLAGS@
++ALL_CFLAGS = @CFLAGS@
+
+
+
+diff -Naur mead-2.2.7-orig/swig/Makefile.in mead-2.2.7/swig/Makefile.in
+--- mead-2.2.7-orig/swig/Makefile.in 2007-11-27 15:57:17.000000000 -0600
++++ mead-2.2.7/swig/Makefile.in 2009-02-15 16:34:35.000000000 -0600
+@@ -58,7 +58,7 @@
+ CXX_FLAGS = @CXX_NOOPTFLAGS@ @CXX_DEBUGFLAGS@ @CXX_SHAREDFLAGS@
+ CXX_DYNLIB_FLAGS = @CXX_DYNLIB_FLAGS@
+
+-ALL_CXXFLAGS = $(CPP_FLAGS) $(CXX_FLAGS)
++ALL_CXXFLAGS = $(CPP_FLAGS) @CXXFLAGS@ @CXX_SHAREDFLAGS@
+
+ MEADINC = -I$(top_srcdir) -I$(srcdir)
+ MEADLIBS = -L../libmead -lmead
diff --git a/sci-chemistry/mead/files/mead-2.2.7-respect-flags.patch b/sci-chemistry/mead/files/mead-2.2.7-respect-flags.patch
new file mode 100644
index 000000000000..9ffb238ece8c
--- /dev/null
+++ b/sci-chemistry/mead/files/mead-2.2.7-respect-flags.patch
@@ -0,0 +1,74 @@
+diff --git a/apps/Makefile.common.in b/apps/Makefile.common.in
+index 15c61ae..f15d71d 100644
+--- a/apps/Makefile.common.in
++++ b/apps/Makefile.common.in
+@@ -36,10 +36,10 @@ REGEX_CPP = @REGEX_CPP@
+ LIBS = @LIBS@ -lm
+
+ ALL_CPPFLAGS = -I. $(LOCALINCS) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
+-ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS)
+-ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
++ALL_CXXFLAGS = @CXXFLAGS@
++ALL_CFLAGS = @CFLAGS@
+
+-CXXLINK = $(CXX) $(ALL_CPPFLAGS) $(CXX_DEBUGFLAGS) $(CXX_OPTFLAGS) \
++CXXLINK = $(CXX) $(ALL_CPPFLAGS) @CXXFLAGS@ \
+ $(LDFLAGS)
+
+ .SUFFIXES: .cc .o
+diff --git a/apps/libmso/Makefile.in b/apps/libmso/Makefile.in
+index 249c25b..9d23665 100644
+--- a/apps/libmso/Makefile.in
++++ b/apps/libmso/Makefile.in
+@@ -35,8 +35,8 @@ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+
+ ALL_CPPFLAGS = -I. $(LOCALINCS) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
+-ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS)
+-ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
++ALL_CXXFLAGS = @CXXFLAGS@
++ALL_CFLAGS = @CFLAGS@
+
+ .SUFFIXES:
+ .SUFFIXES: .cc .o
+diff --git a/apps/redti/Makefile.in b/apps/redti/Makefile.in
+index c4aa5ca..9561bf3 100644
+--- a/apps/redti/Makefile.in
++++ b/apps/redti/Makefile.in
+@@ -21,7 +21,7 @@ CFLAGS = @CFLAGS@
+ redti_objs = redti.o rfixpro.o rfixprosee.o pfix.o tc.o
+
+ redti : $(redti_objs)
+- $(CC) $(CFLAGS) $(redti_objs) -lm -o redti
++ $(CC) $(CFLAGS) $(LDFLAGS) $(redti_objs) -lm -o redti
+
+ appname = redti
+ include ../Makefile.common
+diff --git a/libmead/Makefile.in b/libmead/Makefile.in
+index 3d4d5f0..8b4a4ac 100644
+--- a/libmead/Makefile.in
++++ b/libmead/Makefile.in
+@@ -99,8 +99,8 @@ PYTHONINC = @PYTHONINC@
+ INCLUDES = -I$(top_srcdir)
+
+ ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
+-ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS) $(CXX_SHAREDFLAGS)
+-ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
++ALL_CXXFLAGS = @CXXFLAGS@
++ALL_CFLAGS = @CFLAGS@
+
+
+
+diff --git a/swig/Makefile.in b/swig/Makefile.in
+index 81b3b4e..8410307 100644
+--- a/swig/Makefile.in
++++ b/swig/Makefile.in
+@@ -58,7 +58,7 @@ CPP_FLAGS = -DSWIG @CPPFLAGS@
+ CXX_FLAGS = @CXX_NOOPTFLAGS@ @CXX_DEBUGFLAGS@ @CXX_SHAREDFLAGS@
+ CXX_DYNLIB_FLAGS = @CXX_DYNLIB_FLAGS@
+
+-ALL_CXXFLAGS = $(CPP_FLAGS) $(CXX_FLAGS)
++ALL_CXXFLAGS = $(CPP_FLAGS) @CXXFLAGS@ @CXX_SHAREDFLAGS@
+
+ MEADINC = -I$(top_srcdir) -I$(srcdir)
+ MEADLIBS = -L../libmead -lmead