summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/mm-align
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/mm-align')
-rw-r--r--sci-chemistry/mm-align/Manifest1
-rw-r--r--sci-chemistry/mm-align/files/CMakeLists.txt5
-rw-r--r--sci-chemistry/mm-align/metadata.xml26
-rw-r--r--sci-chemistry/mm-align/mm-align-20120321.ebuild22
4 files changed, 54 insertions, 0 deletions
diff --git a/sci-chemistry/mm-align/Manifest b/sci-chemistry/mm-align/Manifest
new file mode 100644
index 000000000000..a1e08c44269c
--- /dev/null
+++ b/sci-chemistry/mm-align/Manifest
@@ -0,0 +1 @@
+DIST MM-align-20120321.tar.xz 20072 SHA256 0158a93a06257b885630ab7bed3b7bf8dca2ee12217c84d019829a1e34f3eeb3
diff --git a/sci-chemistry/mm-align/files/CMakeLists.txt b/sci-chemistry/mm-align/files/CMakeLists.txt
new file mode 100644
index 000000000000..635ffdd67418
--- /dev/null
+++ b/sci-chemistry/mm-align/files/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required (VERSION 2.6)
+project (MM-align Fortran)
+add_executable(MMalign MM-align.f)
+
+install (TARGETS MMalign DESTINATION bin)
diff --git a/sci-chemistry/mm-align/metadata.xml b/sci-chemistry/mm-align/metadata.xml
new file mode 100644
index 000000000000..2634f696a953
--- /dev/null
+++ b/sci-chemistry/mm-align/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+MM-align is an algorithm for structurally aligning multiple-chain
+protein-protein complexes. The algorithm is built on a heuristic
+iteration of a modified Needleman-Wunsch dynamic programming (DP)
+algorithm, with the alignment score specified by the inter-complex residue
+distances. The multiple chains in each complex are first joined, in every
+possible order, and then simultaneously aligned with cross-chain alignments
+prevented. The alignments of interface residues are enhanced by an
+interface-specific weighting factor. An optimal alignment between two complexes,
+as well as the overall TM-score, will be reported for each comparison.
+What is the difference between TM-align and MM-align? TM-align is for aligning
+monomer protein structures while MM-align is designed for aligning
+multiple-chain protein complex structures. Although one can still use TM-align
+to align protein complexes after manually joining the chains, this will lead
+to suboptimal alignments with unphysical cross alignments. Therefore, the
+best result will be obtained if one uses TM-align to monomer structures and
+MM-align for multimer structures.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/mm-align/mm-align-20120321.ebuild b/sci-chemistry/mm-align/mm-align-20120321.ebuild
new file mode 100644
index 000000000000..c0ef57c832af
--- /dev/null
+++ b/sci-chemistry/mm-align/mm-align-20120321.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Protein Complex Structural Alignment"
+HOMEPAGE="http://zhanglab.ccmb.med.umich.edu/MM-align/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/MM-align-${PV}.tar.xz"
+
+SLOT="0"
+LICENSE="tm-align"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+}