summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/molsketch/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/molsketch/files')
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch54
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.3.0-_DEFAULT_SOURCE.patch16
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.3.0-desktop.patch19
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.3.0-no-quotes.patch16
4 files changed, 105 insertions, 0 deletions
diff --git a/sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch b/sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch
new file mode 100644
index 000000000000..41ddf01df5f8
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch
@@ -0,0 +1,54 @@
+ CMakeLists.txt | 12 ++++++------
+ libmolsketch/src/stereocenteritem.cpp | 2 +-
+ 2 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a4b5d29..f472b40 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,10 +12,10 @@ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
+ # compiler issues are fixed and more warnings are issued. #
+ ###########################################################
+ if (CMAKE_COMPILER_IS_GNUCXX)
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror-implicit-function-declaration -Wchar-subscripts")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wmissing-format-attribute -fno-common")
++# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align")
++# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror-implicit-function-declaration -Wchar-subscripts")
++# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security")
++# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wmissing-format-attribute -fno-common")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-exceptions -fno-check-new -fno-common")
+@@ -32,7 +32,7 @@ set(CPACK_SOURCE_IGNORE_FILES "/build;/.git")
+ include(CPack)
+
+ # Unit testing, mainly useful for developers and so defaults to off
+-option(ENABLE_TESTS "Enable unit testing" ON)
++option(ENABLE_TESTS "Enable unit testing" OFF)
+ if(ENABLE_TESTS)
+ set(QT_USE_QTTEST TRUE)
+ enable_testing()
+@@ -48,7 +48,7 @@ configure_file("${CMAKE_MODULE_PATH}/cmake_uninstall.cmake.in"
+ add_custom_target(uninstall "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
+
+ # Enabling debugging symbols
+-set(CMAKE_BUILD_TYPE Debug)
++# set(CMAKE_BUILD_TYPE Debug)
+
+ # Enabling shared libraries
+ set(BUILD_SHARED_LIBS OFF)
+diff --git a/libmolsketch/src/stereocenteritem.cpp b/libmolsketch/src/stereocenteritem.cpp
+index 44a8015..20f2a4a 100644
+--- a/libmolsketch/src/stereocenteritem.cpp
++++ b/libmolsketch/src/stereocenteritem.cpp
+@@ -63,7 +63,7 @@ namespace Molsketch {
+ graphsym.GetSymmetry(symmetry_classes);
+
+ //std::vector<unsigned long> atomIds = FindTetrahedralAtoms(obmol, symmetry_classes);
+- std::vector<OpenBabel::StereogenicUnit> units = FindStereogenicUnits(obmol, symmetry_classes);
++ OpenBabel::OBStereoUnitSet units = FindStereogenicUnits(obmol, symmetry_classes);
+
+ for (unsigned int i = 0; i < units.size(); ++i) {
+ if (units.at(i).type == OpenBabel::OBStereo::Tetrahedral) {
diff --git a/sci-chemistry/molsketch/files/molsketch-0.3.0-_DEFAULT_SOURCE.patch b/sci-chemistry/molsketch/files/molsketch-0.3.0-_DEFAULT_SOURCE.patch
new file mode 100644
index 000000000000..af3b5ceedac6
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.3.0-_DEFAULT_SOURCE.patch
@@ -0,0 +1,16 @@
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e3cd0fe..64c18a2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -19,7 +19,7 @@ if (CMAKE_COMPILER_IS_GNUCXX)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-exceptions -fno-check-new -fno-common")
+- add_definitions(-D_BSD_SOURCE)
++ add_definitions(-D_DEFAULT_SOURCE)
+ endif (CMAKE_COMPILER_IS_GNUCXX)
+
+ # Enable CPack
diff --git a/sci-chemistry/molsketch/files/molsketch-0.3.0-desktop.patch b/sci-chemistry/molsketch/files/molsketch-0.3.0-desktop.patch
new file mode 100644
index 000000000000..fd44e88c7870
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.3.0-desktop.patch
@@ -0,0 +1,19 @@
+ molsketch/src/molsketch.desktop | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/molsketch/src/molsketch.desktop b/molsketch/src/molsketch.desktop
+index a4a5418..4e0a2ef 100644
+--- a/molsketch/src/molsketch.desktop
++++ b/molsketch/src/molsketch.desktop
+@@ -5,9 +5,9 @@ Type=Application
+ Name=molsKetch
+ TryExec=molsketch
+ Exec=molsketch
+-Icon=molsketch.png
++Icon=molsketch
+ DocPath=molsketch/index.html
+-MimeType=chemical/x-cml
++MimeType=chemical/x-cml;
+ Terminal=false
+ Categories=Qt;Education;Science;
+ GenericName=2D molecular structures editor
diff --git a/sci-chemistry/molsketch/files/molsketch-0.3.0-no-quotes.patch b/sci-chemistry/molsketch/files/molsketch-0.3.0-no-quotes.patch
new file mode 100644
index 000000000000..db7be800e385
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.3.0-no-quotes.patch
@@ -0,0 +1,16 @@
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 64c18a2..75c2fb7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -97,7 +97,7 @@ endif(Qt5Core_FOUND AND Qt5Widgets_FOUND AND Qt5Gui_FOUND AND Qt5PrintSupport_FO
+ if(FORCEQt4)
+ add_definitions(-DQTVERSIONSUFFIX="")
+ else(FORCEQt4)
+- add_definitions(-DQTVERSIONSUFFIX="\\\"-qt5\\\"")
++ add_definitions(-DQTVERSIONSUFFIX="-qt5")
+ endif(FORCEQt4)
+
+ # and OpenBabel2