summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-08-14 12:13:19 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-14 12:13:19 +0200
commit0ddb3aef19714993e4c6da71d4c2d9a00c2754cb (patch)
tree5a47a20c1744fc2c617f5a44d73d8272a53fd823 /sci-chemistry/mopac7
parentsci-chemistry/theseus: Port to EAPI 8 (diff)
downloadgentoo-0ddb3aef19714993e4c6da71d4c2d9a00c2754cb.tar.gz
gentoo-0ddb3aef19714993e4c6da71d4c2d9a00c2754cb.tar.bz2
gentoo-0ddb3aef19714993e4c6da71d4c2d9a00c2754cb.zip
sci-chemistry/mopac7: Port to EAPI 8
Closes: https://bugs.gentoo.org/454896 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry/mopac7')
-rw-r--r--sci-chemistry/mopac7/mopac7-1.15-r1.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/sci-chemistry/mopac7/mopac7-1.15-r1.ebuild b/sci-chemistry/mopac7/mopac7-1.15-r1.ebuild
index 3cb18cba78fe..aaf87bceee5c 100644
--- a/sci-chemistry/mopac7/mopac7-1.15-r1.ebuild
+++ b/sci-chemistry/mopac7/mopac7-1.15-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
inherit autotools fortran-2 flag-o-matic toolchain-funcs
@@ -21,6 +21,8 @@ DEPEND="dev-libs/libf2c"
RDEPEND="${DEPEND}"
src_prepare() {
+ default
+
# Install the executable
sed -i \
-e "s:noinst_PROGRAMS = mopac7:bin_PROGRAMS = mopac7:g" \
@@ -44,11 +46,12 @@ src_compile() {
emake
if use gmxmopac7; then
einfo "Making mopac7 lib for gromacs"
- mkdir "${S}"/fortran/libgmxmopac7 && cd "${S}"/fortran/libgmxmopac7
- cp -f ../SIZES ../*.f "${FILESDIR}"/Makefile . || die
+ mkdir "${S}"/fortran/libgmxmopac7 || die
+ cd "${S}"/fortran/libgmxmopac7 || die
+ cp -n ../SIZES ../*.f "${FILESDIR}"/Makefile . || die
emake clean
- cp -f "${DISTDIR}"/gmxmop.f "${DISTDIR}"/dcart.f . || die
- sed "s:GENTOOVERSION:${PV}:g" -i Makefile
+ cp -n "${DISTDIR}"/gmxmop.f "${DISTDIR}"/dcart.f . || die
+ sed "s:GENTOOVERSION:${PV}:g" -i Makefile || die
emake FC=$(tc-getFC)
fi
}
@@ -61,7 +64,7 @@ src_install() {
default
if use gmxmopac7; then
- cd "${S}"/fortran/libgmxmopac7
+ cd "${S}"/fortran/libgmxmopac7 || die
dolib.so libgmxmopac7.so*
fi