summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-16 22:16:40 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-16 22:16:40 +0200
commit5174a8d7df32f459b6a983ffc50907b678a15954 (patch)
tree2d756dfe9cf83d5073e6cea0a891779e77a66cf9 /sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild
parentsci-chemistry/moldy: Port to EAPI 7 (diff)
downloadgentoo-5174a8d7df32f459b6a983ffc50907b678a15954.tar.gz
gentoo-5174a8d7df32f459b6a983ffc50907b678a15954.tar.bz2
gentoo-5174a8d7df32f459b6a983ffc50907b678a15954.zip
sci-chemistry/msms-bin: Port to EAPI 7
Closes: https://bugs.gentoo.org/742005 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild')
-rw-r--r--sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild b/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild
index 13eebfcdc23e..6f6335e72bf8 100644
--- a/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild
+++ b/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild
@@ -1,25 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="MSMS very efficiently computes triangulations of Solvent Excluded Surfaces"
HOMEPAGE="http://mgl.scripps.edu/people/sanner/html/msms_home.html"
SRC_URI="
- amd64? ( msms_i86_64Linux2_2.6.1.tar.gz )
- x86? ( msms_i86Linux2_2.6.1.tar.gz )
-"
+ amd64? ( msms_i86_64Linux2_2.6.1.tar.gz )
+ x86? ( msms_i86Linux2_2.6.1.tar.gz )"
LICENSE="MSMS"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
RESTRICT="fetch"
S="${WORKDIR}"
-QA_PREBUILT="${EROOT#/}opt/bin/.*"
+QA_PREBUILT="opt/bin/*"
pkg_nofetch() {
einfo "Please download ${A} from http://mgltools.scripps.edu/downloads#msms and"
@@ -27,19 +24,18 @@ pkg_nofetch() {
}
src_install() {
- doman msms.1
- dodoc README msms.html ReleaseNotes
+ dobin pdb_to_xyz*
+
exeinto /opt/bin
- if use amd64; then
- newexe ${PN%-bin}.x86_64Linux2.${PV} msms
- elif use x86; then
- newexe ${PN%-bin}.i86Linux2.${PV} msms
- fi
+ newexe ${PN%-bin}.$(usex amd64 x86_64Linux2 i86Linux2).${PV} msms
+
+ dodoc README msms.html ReleaseNotes
+ doman msms.1
+
insinto /usr/share/${PN}/
doins atmtypenumbers
sed \
-e 's:nawk:awk:g' \
-e "s:./atmtypenumbers:${EPREFIX}/usr/share/${PN}/atmtypenumbers:g" \
-i pdb_to_xyz* || die
- dobin pdb_to_xyz*
}