summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-01 02:49:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-01 02:50:42 +0100
commit8929cccdec39a6b8c5ac04972f2d7ef3e93f55e8 (patch)
tree3df762a0b7384e4a1a6fc7f3369d20aad8d0d1aa /sci-chemistry/nmrglue
parentsci-chemistry/mdtraj: Remove old (py3.6) (diff)
downloadgentoo-8929cccdec39a6b8c5ac04972f2d7ef3e93f55e8.tar.gz
gentoo-8929cccdec39a6b8c5ac04972f2d7ef3e93f55e8.tar.bz2
gentoo-8929cccdec39a6b8c5ac04972f2d7ef3e93f55e8.zip
sci-chemistry/nmrglue: Remove old (py3.6)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-chemistry/nmrglue')
-rw-r--r--sci-chemistry/nmrglue/Manifest1
-rw-r--r--sci-chemistry/nmrglue/files/nmrglue-0.5-nohyper.patch33
-rw-r--r--sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild35
3 files changed, 0 insertions, 69 deletions
diff --git a/sci-chemistry/nmrglue/Manifest b/sci-chemistry/nmrglue/Manifest
index b1414f469d94..a887763be6c1 100644
--- a/sci-chemistry/nmrglue/Manifest
+++ b/sci-chemistry/nmrglue/Manifest
@@ -1,2 +1 @@
-DIST nmrglue-0.5.tar.gz 142604 BLAKE2B 9a018a73bea46176fc06042013cb23b3eeb962df8a595388da536d17f1d2d4d550065c5492df28de860ea1290314d2fa1110af349be0c2a8b1b31677b3e4afbc SHA512 2a4b94eb6bae966000bfdee4dd16f4e312568915fb5f19f59f84c6deff690703f54f76366d3f9299f7ec187192ff64f2bf62836617a424d4c5c895c67d819af2
DIST nmrglue-0.7.tar.gz 166596 BLAKE2B 769dbe1330a2b610393cea07edcb7c997d219038ead0330e442b491b84a51f3d1ac0dd22a9399b1af2f97fbfbf0d24316bd834d71804b4607209c5d11f24939e SHA512 4d9959d151954f38efc7ea4f93539970bc75098403b0b5575f0c4ff6c2c25c1f08e207d2dee281109ffb2bdea53f2e7beb04e251cec1f638712dfe38430c23d5
diff --git a/sci-chemistry/nmrglue/files/nmrglue-0.5-nohyper.patch b/sci-chemistry/nmrglue/files/nmrglue-0.5-nohyper.patch
deleted file mode 100644
index 103f5b154d0b..000000000000
--- a/sci-chemistry/nmrglue/files/nmrglue-0.5-nohyper.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From ba1eee9e71623110511545c058afe2a92e139aa5 Mon Sep 17 00:00:00 2001
-From: Jonathan Helmus <jjhelmus@gmail.com>
-Date: Tue, 3 Mar 2015 19:47:05 -0600
-Subject: [PATCH] pipe_proc.py tp function correctly sets FDSIZE.
-
-Fixes issue #27
----
- nmrglue/process/pipe_proc.py | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/nmrglue/process/pipe_proc.py b/nmrglue/process/pipe_proc.py
-index 79b6303..8c1271c 100644
---- a/nmrglue/process/pipe_proc.py
-+++ b/nmrglue/process/pipe_proc.py
-@@ -1527,13 +1527,16 @@ def tp(dic, data, hyper=False, nohyper=False, auto=False, nohdr=False):
- data = np.array(p.tp_hyper(data), dtype="complex64")
- else:
- data = p.tp(data)
-- if dic[fn2 + "QUADFLAG"] != 1 and nohyper is not True:
-+ if dic[fn2 + "QUADFLAG"] != 1 and nohyper is False:
- # unpack complex as needed
- data = np.array(p.c2ri(data), dtype="complex64")
-
- # update the dimentionality and order
- dic["FDSLICECOUNT"] = data.shape[0]
-- if data.dtype == 'float32':
-+ if (data.dtype == 'float32') and (nohyper is True):
-+ # when nohyper is True and the new last dimension was complex
-+ # prior to transposing then FDSIZE is set as if the dimension was
-+ # converted to complex data, that is half the actual size.
- dic["FDSIZE"] = data.shape[1] / 2
- else:
- dic["FDSIZE"] = data.shape[1]
diff --git a/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild b/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild
deleted file mode 100644
index 3a767944a130..000000000000
--- a/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A module for working with NMR data in Python"
-HOMEPAGE="https://nmrglue.com/"
-SRC_URI="https://github.com/jjhelmus/nmrglue/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-nohyper.patch )
-
-python_test() {
- nosetests --verbosity=3 || die
-}