summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-27 18:37:08 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-27 19:04:04 +0100
commit67637da7accee22cb299954e4aaa831fe2d6faec (patch)
tree67d456d0a05812fa5bc8ea86e71de713024ec3db /sci-chemistry/openbabel
parentsys-kernel/gentoo-sources: Linux patch 4.1.12 (diff)
downloadgentoo-67637da7accee22cb299954e4aaa831fe2d6faec.tar.gz
gentoo-67637da7accee22cb299954e4aaa831fe2d6faec.tar.bz2
gentoo-67637da7accee22cb299954e4aaa831fe2d6faec.zip
sci-chemistry/openbabel: Fix for gcc-5
convert mycmakeargs to be an array Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/openbabel')
-rw-r--r--sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild b/sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild
index c123bb0ab339..81b5302bbd85 100644
--- a/sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild
+++ b/sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild
@@ -41,13 +41,21 @@ pkg_setup() {
fi
}
+src_prepare() {
+ sed \
+ -e '/__GNUC__/s:== 4:>= 4:g' \
+ -i include/openbabel/shared_ptr.h || die
+ cmake-utils_src_prepare
+}
+
src_configure() {
need-wxwidgets unicode
- local mycmakeargs=""
- mycmakeargs="${mycmakeargs}
+ local mycmakeargs=()
+ mycmakeargs+=(
-DOPENBABEL_USE_SYSTEM_INCHI=ON
$(cmake-utils_use_enable openmp OPENMP)
- $(cmake-utils_use wxwidgets BUILD_GUI)"
+ $(cmake-utils_use wxwidgets BUILD_GUI)
+ )
cmake-utils_src_configure
}