summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/prodecomp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/prodecomp')
-rw-r--r--sci-chemistry/prodecomp/Manifest1
-rw-r--r--sci-chemistry/prodecomp/metadata.xml18
-rw-r--r--sci-chemistry/prodecomp/prodecomp-3.0.ebuild46
3 files changed, 65 insertions, 0 deletions
diff --git a/sci-chemistry/prodecomp/Manifest b/sci-chemistry/prodecomp/Manifest
new file mode 100644
index 000000000000..ffead0387fc2
--- /dev/null
+++ b/sci-chemistry/prodecomp/Manifest
@@ -0,0 +1 @@
+DIST prodecomp-3.0.tar.bz2 18377446 SHA256 097b97aa6503ff1aecd4147a6e3ef9997807773a7ef58aab8b10baf73b65e457 SHA512 8d23f174e125d4c7776432a37b063d2f39af8497050bd7f7ff358c67d509b1eef2c2865596efae632855fd583fb52c233b67d0e667c6c2a03ba6f5a2f2ac9b0d WHIRLPOOL c06f4bf32e3d5ff4f2b5f1b1c4fd03d7a5b734651707e6fc101ce0ea5ba17c9377edb60166c4e9313b616b37bd580febea01bf62a71e15389174b301c4d70738
diff --git a/sci-chemistry/prodecomp/metadata.xml b/sci-chemistry/prodecomp/metadata.xml
new file mode 100644
index 000000000000..a91e9092dc52
--- /dev/null
+++ b/sci-chemistry/prodecomp/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ PRODECOMP (PROjection DECOMPosition) is a software tool for
+ decomposition of 2D projections of high-dimensional NMR spectra to a set
+ of components (defined in turn by one-dimensional "shapes").
+ Simultaneous analysis of projections from one or several
+ high-dimensional experiments provide unambigous chemical shifts for
+ large spin systems. The latter can be used for backbone and side-chain
+ assignments as well as structural studies of proteins
+ (Malmodin and Billeter 2005; 2006; Staykova et al. 2008a,b).
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/prodecomp/prodecomp-3.0.ebuild b/sci-chemistry/prodecomp/prodecomp-3.0.ebuild
new file mode 100644
index 000000000000..28791c9108ba
--- /dev/null
+++ b/sci-chemistry/prodecomp/prodecomp-3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1
+
+DESCRIPTION="Decomposition-based analysis of NMR projections"
+HOMEPAGE="http://www.lundberg.gu.se/nmr/software.php?program=PRODECOMP"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND=""
+
+S="${WORKDIR}"/NMRProjAnalys
+
+src_install() {
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r ExampleData Results
+ fi
+
+ dodoc ProjTools/Manual.pdf
+ rm -rf ProjTools/Manual.pdf ProdecompOutput || die
+
+ python_moduleinto ${PN}
+ python_domodule ProjTools/.
+ python_optimize
+
+ cat >> "${T}"/${PN} <<- EOF
+ #!/bin/bash
+ ${PYTHON} -O "${EPREFIX}"/$(python_get_sitedir)/${PN}/ProjAnalys.py $@
+ EOF
+ dobin "${T}"/${PN}
+
+ dosym ../../../../share/doc/${PF}/Manual.pdf $(python_get_sitedir)/${PN}/Manual.pdf
+}