summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/pymol-plugins-bni-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/pymol-plugins-bni-tools')
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/Manifest2
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/metadata.xml12
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.25.1.ebuild41
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild35
4 files changed, 90 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-bni-tools/Manifest b/sci-chemistry/pymol-plugins-bni-tools/Manifest
new file mode 100644
index 000000000000..532cf761f73b
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/Manifest
@@ -0,0 +1,2 @@
+DIST bni-tools-0.251.zip 32596 SHA256 79f77ecb5797de49249c571eda958a97647f34f456bcda952e4b63ffd0c412d2 SHA512 0d28433679fff1d4473469078ef3b9091f4ed13ccf414d4c54afadcde2f120768f26c0aaee378f04fd9cc71159f21ad7f9281a163a365106dadc3f641b743b76 WHIRLPOOL 4f869b2a357b6c1be6077f478b7356e4bba14ae7a4ef7c17357f6729888439d4c3b09cb27271585258024f39f2fe2437016dd7bec3301e849de453add25330d9
+DIST bni-tools-027.zip 33753 SHA256 9ddb9785146b12c5c2ff03d34262fec8ff04bfaa9c56ec4665bac5e33879cd7c SHA512 9c0ef1ca5bbb3040192ab2668f354f947e93d42c91a0cfdde5d05be273e6ba9f29ec3c6ee86367f18d87316282b4e0141183b8d6259bd36d44010b7bbb7666e5 WHIRLPOOL 7e14a2ef86009237f53e28f6ac95b56687dd7275e8bd8a856c4d408a6c57cffb7131cb9a505d01da7b2f58bf20bae9b400e478d994bb04f9e799ecf09a60edd3
diff --git a/sci-chemistry/pymol-plugins-bni-tools/metadata.xml b/sci-chemistry/pymol-plugins-bni-tools/metadata.xml
new file mode 100644
index 000000000000..c4982f1db5fb
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher (jlec)</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">bni-tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.25.1.ebuild b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.25.1.ebuild
new file mode 100644
index 000000000000..640cf969c61e
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.25.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python versionator
+
+MY_PN="${PN#pymol-plugins-}"
+MY_P="${MY_PN}-$(delete_version_separator 2)"
+
+DESCRIPTION="Gives Pymol additional functionalities and presets to the PyMOL GUI"
+HOMEPAGE="http://bni-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.zip"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-chemistry/pymol"
+DEPEND="app-arch/unzip"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+src_install(){
+ installation() {
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins bni-tools.py || die "Failed to install ${P}"
+ }
+ python_execute_function installation
+ dodoc readme.txt || die "No dodoc"
+}
+
+pkg_postinst(){
+ python_mod_optimize pmg_tk/startup
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup
+}
diff --git a/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild
new file mode 100644
index 000000000000..8ade4b32c540
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 versionator
+
+MY_PN="${PN#pymol-plugins-}"
+MY_P="${MY_PN}-$(delete_version_separator 1)"
+MY_P_DOT="${MY_PN}-${PV}"
+
+DESCRIPTION="Gives Pymol additional functionalities and presets to the PyMOL GUI"
+HOMEPAGE="http://bni-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${MY_P_DOT}/${MY_P}.zip"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install(){
+ python_moduleinto pmg_tk/startup
+ python_parallel_foreach_impl python_domodule bni-tools.py
+ python_parallel_foreach_impl python_optimize
+ dodoc readme.txt
+ dohtml ShortCommandDescription.html
+}