summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-10-23 10:09:44 +0200
committerJustin Lecher <jlec@gentoo.org>2016-10-23 22:25:08 +0200
commite55d1db83008e1d11d18727843a4c8f0d14b36f5 (patch)
tree74d9563c105b56a6566f818a625be8e6c827d9ca /sci-chemistry/pymol
parentwww-client/chromium: beta channel bump (55.0.2883.21) (diff)
downloadgentoo-e55d1db83008e1d11d18727843a4c8f0d14b36f5.tar.gz
gentoo-e55d1db83008e1d11d18727843a4c8f0d14b36f5.tar.bz2
gentoo-e55d1db83008e1d11d18727843a4c8f0d14b36f5.zip
sci-chemistry/pymol: Version Bump
Package-Manager: portage-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/Manifest1
-rw-r--r--sci-chemistry/pymol/pymol-1.8.4.0.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index 31c317608f0e..104bc1a85053 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -2,3 +2,4 @@ DIST pymol-1.7.0.0.png.xz 5392 SHA256 4c554a5c4f47946b6f7bae00209d51163051625342
DIST pymol-1.7.6.0.tar.xz 6510380 SHA256 31d4924378b38b65fae5b294e0755ee15916f9e845ef2efe5e2421f463bf3b91 SHA512 ff8c37de07e0ed8dc1176224eea439109f2bd5e42b5c08316f5737a2fdcf5a1f267b625c166fa740296c20ef089873ae1ad6cb89b11111e9d3aeda0b6035d55d WHIRLPOOL 3582cc846695ca580a4bcd31db8079f32d3cb0d84b8fa1afeb0b210d7004642bf58eab42cafd552f360a5e20b546e554cf5420b7dd2e8cefa5b956a9453215e2
DIST pymol-1.7.7.2.tar.xz 6527780 SHA256 fc15fc8fbf23b422c5d19babd20e19b7d7ab8ee9532012c7b3a27b87af44fdae SHA512 faf3715cd6b9e7115f6501fc4480a6f71fe53d3b02b2eeefdd07a57d7c15b3621c05fd3894bb92ac4042edaa224d99c2be7488a762254d069c581974a0146179 WHIRLPOOL b52683ce1dc265fe302c974ccc1bfa9e55365e8502f944cf6527c0071f207fcb54e8b3ad38fd684b66c66f85fa6a03f2f1178b90fd406b9f7561d956c704fb9a
DIST pymol-v1.8.2.1.tar.bz2 8694029 SHA256 fc5d33d7e36364567462cee19b9b132530a83cbab3fafcf373f2a17f127b3f4e SHA512 c6768ab75f715e48fbaa3d0c0664f717b05212c6d004cacea0e9a79ead98375ae7773b4a5c4c476a3b3731be910e3df585b2980fd97fd3fb2afb5ec91304adce WHIRLPOOL 4ad164a3629e15df12ce75a769e34b1af2f87f68f88988919c0d0e8d80fe4062283102003d222040b9a8f0bd91e756eac494e67477242b48cd04947d34cb7c48
+DIST pymol-v1.8.4.0.tar.bz2 8717344 SHA256 b6147befe74844dd23550461b831b2fa6d170d4456f0059cf93fb1e8cb43d279 SHA512 73a810adfc31adaf0f3fa25512084882c87b0782c8af716ac0203a5b5b7f0b9fedfbce3d129bffef7b52044e92b0542e683966b2acf961c4dac17fbba72dd7fe WHIRLPOOL 3943a619ca00cc2bfb51ff4dffa0166856b4425c7518d91b1ff2a048caa53dcb7411c64b246014b860b7f036de582e9efdc09783b3918283f0a96ee5130c7287
diff --git a/sci-chemistry/pymol/pymol-1.8.4.0.ebuild b/sci-chemistry/pymol/pymol-1.8.4.0.ebuild
new file mode 100644
index 000000000000..44305d6d1df7
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.8.4.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 eutils fdo-mime flag-o-matic versionator
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="http://www.pymol.org/"
+SRC_URI="
+ https://dev.gentoo.org/~jlec/distfiles/${PN}-1.7.0.0.png.xz
+ mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1-2)/${PN}-v${PV}.tar.bz2
+ "
+# git archive -v --prefix=${P}/ master -o ${P}.tar.xz
+RESTRICT="mirror"
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="web"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ media-libs/freeglut
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/libpng:0=
+ media-video/mpeg-tools
+ sys-libs/zlib
+ virtual/python-pmw[${PYTHON_USEDEP}]
+ !sci-chemistry/pymol-apbs-plugin[${PYTHON_USEDEP}]
+ web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+python_prepare_all() {
+ sed \
+ -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
+ -e "/import/s:argparse:argparseX:g" \
+ -i setup.py || die
+
+ sed \
+ -e "s:/opt/local:${EPREFIX}/usr:g" \
+ -e '/ext_comp_args/s:\[.*\]:[]:g' \
+ -i setup.py || die
+
+ append-cxxflags -std=c++0x
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install --pymol-path="${EPREFIX}/usr/share/pymol"
+
+ sed \
+ -e '1d' \
+ -e "/APBS_BINARY_LOCATION/s:None:\"${EPREFIX}/usr/bin/apbs\":g" \
+ -e "/APBS_PSIZE_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/src/\":g" \
+ -e "/APBS_PDB2PQR_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/\":g" \
+ -i "${D}/$(python_get_sitedir)"/pmg_tk/startup/apbs_tools.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ sed \
+ -e '1i#!/usr/bin/env python' \
+ "${D}/$(python_get_sitedir)"/pymol/__init__.py > "${T}"/${PN} || die
+
+ python_foreach_impl python_doscript "${T}"/${PN}
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="${EPREFIX}/usr/share/pymol"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ newicon "${WORKDIR}"/${PN}-1.7.0.0.png ${PN}.png
+ make_desktop_entry ${PN} PyMol ${PN} \
+ "Graphics;Education;Science;Chemistry;" \
+ "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
+
+ if ! use web; then
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
+ fi
+
+ rm -f "${ED}"/usr/share/${PN}/LICENSE || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ optfeature "Electrostatic calculations" sci-chemistry/apbs sci-chemistry/pdb2pqr
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}