summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:48:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 19:08:15 +0100
commit17c2488c366953bf6fe189cde24aa4641935eeec (patch)
tree15c2942789a1323616ccf84abd6cb22dcd4d45cf /sci-chemistry/votca-csg/votca-csg-1.6.4.ebuild
parentsci-libs/votca-tools: Fix EAPI-7 bump, drop unused eclasses (diff)
downloadgentoo-17c2488c366953bf6fe189cde24aa4641935eeec.tar.gz
gentoo-17c2488c366953bf6fe189cde24aa4641935eeec.tar.bz2
gentoo-17c2488c366953bf6fe189cde24aa4641935eeec.zip
sci-chemistry/votca-csg: Fix EAPI-7 bump, drop unused multilib
CMAKE_MAKEFILE_GENERATOR=ninja is default in EAPI-7/cmake.eclass Use https Use double brackets Sort RDEPEND Use BDEPEND local mycmakeargs Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-chemistry/votca-csg/votca-csg-1.6.4.ebuild')
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.6.4.ebuild46
1 files changed, 23 insertions, 23 deletions
diff --git a/sci-chemistry/votca-csg/votca-csg-1.6.4.ebuild b/sci-chemistry/votca-csg/votca-csg-1.6.4.ebuild
index 758dcc378f91..4a22a2fb7665 100644
--- a/sci-chemistry/votca-csg/votca-csg-1.6.4.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-1.6.4.ebuild
@@ -3,62 +3,62 @@
EAPI=7
-CMAKE_MAKEFILE_GENERATOR="ninja"
+inherit bash-completion-r1 cmake
-inherit bash-completion-r1 cmake multilib
-
-IUSE="doc examples extras +gromacs hdf5"
-PDEPEND="extras? ( ~sci-chemistry/${PN}apps-${PV} )"
-if [ "${PV}" != "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ PDEPEND="${PDEPEND} doc? ( ~app-doc/${PN}-manual-${PV} )"
+else
SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz
doc? ( https://github.com/${PN/-//}-manual/releases/download/v${PV}/${PN}-manual-${PV}.pdf )
examples? ( https://github.com/${PN/-//}-tutorials/archive/v${PV}.tar.gz -> ${PN}-tutorials-${PV}.tar.gz )"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
S="${WORKDIR}/${P#votca-}"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN/-//}.git"
- PDEPEND="${PDEPEND} doc? ( ~app-doc/${PN}-manual-${PV} )"
+ PDEPEND="extras? ( ~sci-chemistry/${PN}apps-${PV} )"
fi
DESCRIPTION="Votca coarse-graining engine"
-HOMEPAGE="http://www.votca.org"
+HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
+IUSE="doc examples extras +gromacs hdf5"
RDEPEND="
- ~sci-libs/votca-tools-${PV}
+ app-shells/bash:*
>=dev-cpp/eigen-3.3
+ dev-lang/perl
+ ~sci-libs/votca-tools-${PV}
gromacs? ( sci-chemistry/gromacs:= )
hdf5? ( sci-libs/hdf5 )
- dev-lang/perl
- app-shells/bash:*"
-
-DEPEND="${RDEPEND}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
>=app-text/txt2tags-2.5
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
DOCS=( README.md NOTICE CHANGELOG.md )
src_unpack() {
- if [[ ${PV} != *9999 ]]; then
- default
- else
+ if [[ ${PV} == *9999 ]]; then
git-r3_src_unpack
if use examples; then
EGIT_REPO_URI="https://github.com/${PN/-//}-tutorials.git"
EGIT_BRANCH="master"
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PN#votca-}-tutorials"\
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PN#votca-}-tutorials" \
git-r3_src_unpack
fi
+ else
+ default
fi
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DWITH_GMX=$(usex gromacs)
- -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex '!hdf5')
+ -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
-DWITH_RC_FILES=OFF
)
cmake_src_configure