summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-09-03 07:39:27 -0600
committerChristoph Junghans <junghans@gentoo.org>2017-09-03 07:41:02 -0600
commitaa46486d5213af2178325669c1a84311d8b089c7 (patch)
tree12b542362398dcf6536f8757bf7210fad2975743 /sci-chemistry/votca-csgapps/votca-csgapps-1.4.1.ebuild
parentsci-chemistry/votca-csg: version bump (diff)
downloadgentoo-aa46486d5213af2178325669c1a84311d8b089c7.tar.gz
gentoo-aa46486d5213af2178325669c1a84311d8b089c7.tar.bz2
gentoo-aa46486d5213af2178325669c1a84311d8b089c7.zip
sci-chemistry/votca-csgapps: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sci-chemistry/votca-csgapps/votca-csgapps-1.4.1.ebuild')
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-1.4.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-1.4.1.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-1.4.1.ebuild
new file mode 100644
index 000000000000..4112759a2d55
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-1.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="~sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README )