summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2019-11-21 16:04:03 -0700
committerChristoph Junghans <junghans@gentoo.org>2019-11-21 19:26:27 -0700
commitfd8cb42b60a6c4444bef01e1114d6b36507c0795 (patch)
tree218c06ef9ac341e75ab35bee2b3b4cba7e56b039 /sci-chemistry/votca-csgapps/votca-csgapps-1.5.1.ebuild
parentsci-chemistry/votca-csg: version bump (diff)
downloadgentoo-fd8cb42b60a6c4444bef01e1114d6b36507c0795.tar.gz
gentoo-fd8cb42b60a6c4444bef01e1114d6b36507c0795.tar.bz2
gentoo-fd8cb42b60a6c4444bef01e1114d6b36507c0795.zip
sci-chemistry/votca-csgapps: version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry/votca-csgapps/votca-csgapps-1.5.1.ebuild')
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-1.5.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-1.5.1.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-1.5.1.ebuild
new file mode 100644
index 000000000000..a4a0669224d6
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-1.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-cpp/eigen-3.3
+ ~sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README )