summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /sci-chemistry
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/moldy/moldy-2.16e-r2.ebuild2
-rw-r--r--sci-chemistry/p3d/p3d-9999.ebuild2
-rw-r--r--sci-chemistry/surf/surf-1.0.ebuild7
3 files changed, 5 insertions, 6 deletions
diff --git a/sci-chemistry/moldy/moldy-2.16e-r2.ebuild b/sci-chemistry/moldy/moldy-2.16e-r2.ebuild
index 8ba71f621898..0d3399860306 100644
--- a/sci-chemistry/moldy/moldy-2.16e-r2.ebuild
+++ b/sci-chemistry/moldy/moldy-2.16e-r2.ebuild
@@ -61,7 +61,7 @@ src_install() {
if use examples; then
rm Makefile.in configure.in config.h.in
insinto /usr/share/${PN}/examples/
- doins *.in *.out control.* || die
+ doins *.in *.out control.*
fi
if use doc; then
insinto /usr/share/doc/${PF}/pdf
diff --git a/sci-chemistry/p3d/p3d-9999.ebuild b/sci-chemistry/p3d/p3d-9999.ebuild
index f5eb1e8c1b42..5dd3fdc9a942 100644
--- a/sci-chemistry/p3d/p3d-9999.ebuild
+++ b/sci-chemistry/p3d/p3d-9999.ebuild
@@ -22,6 +22,6 @@ src_install() {
if use examples; then
insinto /usr/share/${PN}
- doins -r pdbs exampleScripts || die
+ doins -r pdbs exampleScripts
fi
}
diff --git a/sci-chemistry/surf/surf-1.0.ebuild b/sci-chemistry/surf/surf-1.0.ebuild
index 138830fe777c..5b6ff83975fd 100644
--- a/sci-chemistry/surf/surf-1.0.ebuild
+++ b/sci-chemistry/surf/surf-1.0.ebuild
@@ -33,11 +33,10 @@ src_compile() {
&& emake \
CC="$(tc-getCC)" \
OPT_CFLAGS="${CFLAGS} \$(INCLUDE)" \
- CFLAGS="${CFLAGS} \$(INCLUDE)" \
- || die
+ CFLAGS="${CFLAGS} \$(INCLUDE)"
}
src_install() {
- dobin ${PN} || die
- dodoc README || die
+ dobin ${PN}
+ dodoc README
}