summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-09-03 13:21:22 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-09-03 13:21:45 -0600
commit40003409ab4ef64801ed5422f8f3c23fb0029ffd (patch)
tree687875c6948efcdd7f133586c18adefa5ff67d18 /sci-chemistry
parentdev-vcs/git: Removed old. (diff)
downloadgentoo-40003409ab4ef64801ed5422f8f3c23fb0029ffd.tar.gz
gentoo-40003409ab4ef64801ed5422f8f3c23fb0029ffd.tar.bz2
gentoo-40003409ab4ef64801ed5422f8f3c23fb0029ffd.zip
sci-chemistry/gromacs: fix build with mkl (bug #592786)
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gromacs/gromacs-2016.9999.ebuild8
-rw-r--r--sci-chemistry/gromacs/gromacs-2016.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2016.9999.ebuild b/sci-chemistry/gromacs/gromacs-2016.9999.ebuild
index c4a1a0abc6ed..e5f17d70fca9 100644
--- a/sci-chemistry/gromacs/gromacs-2016.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2016.9999.ebuild
@@ -137,12 +137,18 @@ src_configure() {
-DMKL_INCLUDE_DIR="${MKLROOT}/include"
-DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
)
- elif use mkl; then
+ elif use mkl && has_version "<sci-libs/mkl-11.3"; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
-DMKL_INCLUDE_DIR="$(echo /opt/intel/*/mkl/include)"
-DMKL_LIBRARIES="$(echo /opt/intel/*/mkl/lib/*${bits/lib}/libmkl_rt.so)"
)
+ elif use mkl; then
+ local bits=$(get_libdir)
+ fft_opts=( -DGMX_FFT_LIBRARY=mkl
+ -DMKL_INCLUDE_DIR="$(echo /opt/intel/*/linux/mkl/include)"
+ -DMKL_LIBRARIES="$(echo /opt/intel/*/linux/mkl/lib/*${bits/lib}/libmkl_rt.so)"
+ )
else
fft_opts=( -DGMX_FFT_LIBRARY=fftpack )
fi
diff --git a/sci-chemistry/gromacs/gromacs-2016.ebuild b/sci-chemistry/gromacs/gromacs-2016.ebuild
index c93c50724cc6..9987af8e4ba4 100644
--- a/sci-chemistry/gromacs/gromacs-2016.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2016.ebuild
@@ -135,12 +135,18 @@ src_configure() {
-DMKL_INCLUDE_DIR="${MKLROOT}/include"
-DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
)
- elif use mkl; then
+ elif use mkl && has_version "<sci-libs/mkl-11.3"; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl
-DMKL_INCLUDE_DIR="$(echo /opt/intel/*/mkl/include)"
-DMKL_LIBRARIES="$(echo /opt/intel/*/mkl/lib/*${bits/lib}/libmkl_rt.so)"
)
+ elif use mkl; then
+ local bits=$(get_libdir)
+ fft_opts=( -DGMX_FFT_LIBRARY=mkl
+ -DMKL_INCLUDE_DIR="$(echo /opt/intel/*/linux/mkl/include)"
+ -DMKL_LIBRARIES="$(echo /opt/intel/*/linux/mkl/lib/*${bits/lib}/libmkl_rt.so)"
+ )
else
fft_opts=( -DGMX_FFT_LIBRARY=fftpack )
fi