summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-16 11:20:29 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-16 11:21:15 +0200
commit41450445b1ed716105272105bdb4e9d2e8c4f42d (patch)
tree50d4de4d1c4461eb8bbf91a4a38fc5e479e46b3a /sci-chemistry
parentMerge remote-tracking branch 'remotes/github/pr/177'. (diff)
downloadgentoo-41450445b1ed716105272105bdb4e9d2e8c4f42d.tar.gz
gentoo-41450445b1ed716105272105bdb4e9d2e8c4f42d.tar.bz2
gentoo-41450445b1ed716105272105bdb4e9d2e8c4f42d.zip
sci-chemistry/relax: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/relax/Manifest1
-rw-r--r--sci-chemistry/relax/relax-4.0.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sci-chemistry/relax/Manifest b/sci-chemistry/relax/Manifest
index 42f7f7f33e2b..8953087ac7ce 100644
--- a/sci-chemistry/relax/Manifest
+++ b/sci-chemistry/relax/Manifest
@@ -1,2 +1,3 @@
DIST relax-3.3.8.src.tar.bz2 90271667 SHA256 176d4e9f0f1c6cf6e6c93b12070a50ff31e10c8dbe2c05cfc2b253e51425b12d SHA512 ddc9df4a8da4ec563403003ae5bc9ecdf5f3bb7341e2306c405fcf7953ab67cab93e9f64139465b05acfa2c842da1624d941b481ef77c20804cabe7c9df811f9 WHIRLPOOL 1a7f77fc9cd712b7ca459a1943dffde4e154fa2d5e06b77ec42568b012c4319dd43eb0b85cdfd6116b9ba2584e5bd58e1b0d8ea8524d462ab4e18e33d4fa315e
DIST relax-3.3.9.src.tar.bz2 93403953 SHA256 5bfa0fc774cfafd30e9f593f6b5f368b6bd79faf0ca2e7ae064a8bd3b6923685 SHA512 0af93497acd91e6e4be0cf07efe09198c1234e70641835668a94714d58ad225d5ef94df3225d4d6809aa456e340c05829520f4aa6215cb83f7315ccca2053461 WHIRLPOOL 4ea5bb6582a020df902b9ac28cf5e025456607ddb50b1a6c1915db421ac6ea415781cb9d361fd34b2240500e7d0b74af131984dddcea6b0548dfb76d8b2be378
+DIST relax-4.0.0.src.tar.bz2 105659752 SHA256 4bd27341196d7bf963b269ef41d89b9ac1e1a21200f7911e7c27900d2c0f16d9 SHA512 28b5ddab2c83f95d7e1a502d05b5d3c93337fece68a1fef95ec8978f61fccf24cb37528cfef27cb20d132033535f4120b23cc76a75f34f52b27df17116351f8e WHIRLPOOL 438859c8970f4f16fa9fdf59f7630e3cb07eb0279971b53fa29f6da081c8b3965db0e3f9000efa47d285e44579641222fd74d04b837e453847a1b4dd72acf479
diff --git a/sci-chemistry/relax/relax-4.0.0.ebuild b/sci-chemistry/relax/relax-4.0.0.ebuild
new file mode 100644
index 000000000000..5ffdf922756d
--- /dev/null
+++ b/sci-chemistry/relax/relax-4.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+WX_GTK_VER="2.9"
+
+inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
+
+DESCRIPTION="Molecular dynamics by NMR data analysis"
+HOMEPAGE="http://www.nmr-relax.com/"
+SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/Numdifftools[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
+ sci-chemistry/molmol
+ sci-chemistry/pymol[${PYTHON_USEDEP}]
+ sci-chemistry/vmd
+ >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
+ >=sci-libs/minfx-1.0.11[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-visualization/grace
+ sci-visualization/opendx
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}
+ media-gfx/pngcrush
+ test? ( ${RDEPEND} )
+ "
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -rf minfx bmrblib extern/numdifftools || die
+ tc-export CC
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
+ virtualmake
+}
+
+src_install() {
+ dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf}
+
+ python_moduleinto ${PN}
+ python_domodule *
+
+ rm ${PN} README || die
+
+ make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
+}