summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 12:47:57 +0100
committerSam James <sam@gentoo.org>2021-04-18 07:03:43 +0100
commit7ba727ad4b52fcb4179604a1f567efd94fc109da (patch)
tree92d2826f00dd40b140c3ed0b2f258d53824a8d06 /sci-chemistry
parentsci-chemistry/easychem: eutils->epatch (diff)
downloadgentoo-7ba727ad4b52fcb4179604a1f567efd94fc109da.tar.gz
gentoo-7ba727ad4b52fcb4179604a1f567efd94fc109da.tar.bz2
gentoo-7ba727ad4b52fcb4179604a1f567efd94fc109da.zip
sci-chemistry/gelemental: fix ignored myeconfargs, BDEPEND, xdg-utils->xdg
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gelemental/gelemental-2.0.0-r1.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/sci-chemistry/gelemental/gelemental-2.0.0-r1.ebuild b/sci-chemistry/gelemental/gelemental-2.0.0-r1.ebuild
index 4affe1b9171e..99ac4cd0e9fb 100644
--- a/sci-chemistry/gelemental/gelemental-2.0.0-r1.ebuild
+++ b/sci-chemistry/gelemental/gelemental-2.0.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools eutils flag-o-matic xdg-utils
+inherit autotools flag-o-matic xdg
DESCRIPTION="Periodic table viewer with detailed information on the chemical elements"
HOMEPAGE="https://github.com/ginggs/gelemental/"
@@ -17,11 +17,13 @@ IUSE="doc"
RDEPEND="
dev-cpp/gtkmm:2.4
dev-cpp/glibmm:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/gettext
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/intltool
- doc? ( app-doc/doxygen )"
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
src_prepare() {
default
@@ -30,19 +32,10 @@ src_prepare() {
src_configure() {
append-cxxflags -std=c++11 #566450
- local myeconfargs=( $(use_enable doc api-docs) )
- default
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
+ local myeconfargs=(
+ $(use_enable doc api-docs)
+ )
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+ econf "${myeconfargs[@]}"
}