summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-04 22:19:50 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-04 22:19:50 +0200
commit8aac0d7a2f31b8d788c1c94259df9060df6dd668 (patch)
tree9812493d43bc0f6c0f9efe8e83c9e124abd62d07 /sci-chemistry
parentmedia-video/dvdstyler: need-wxwidgets -> setup-wxwidgets (diff)
downloadgentoo-8aac0d7a2f31b8d788c1c94259df9060df6dd668.tar.gz
gentoo-8aac0d7a2f31b8d788c1c94259df9060df6dd668.tar.bz2
gentoo-8aac0d7a2f31b8d788c1c94259df9060df6dd668.zip
sci-chemistry/wxmacmolplt: need-wxwidgets -> setup-wxwidgets
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
index b102cd19a244..5a5d68427ca7 100644
--- a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
@@ -1,31 +1,30 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER=3.0
-
-inherit autotools eutils wxwidgets
+inherit autotools desktop wxwidgets
DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
SRC_URI="https://wxmacmolplt.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE=""
+KEYWORDS="~amd64 ~x86"
RDEPEND="
media-libs/glew:0=
media-libs/mesa[X(+)]
x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-glew.patch )
src_prepare() {
- need-wxwidgets unicode
- epatch "${FILESDIR}"/${P}-glew.patch
+ default
sed \
-e "/^dist_doc_DATA/d" \
-i Makefile.am || die "Failed to disable installation of LICENSE file"
@@ -33,6 +32,7 @@ src_prepare() {
}
src_configure() {
+ setup-wxwidgets unicode
econf \
--with-glew \
--without-ming
@@ -40,6 +40,7 @@ src_configure() {
src_install() {
default
+
doicon resources/${PN}.png
make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
}