summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-16 19:34:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-16 19:34:50 +0200
commit94ad7eb2a2a84490626fe423556e8c15bb93a8b6 (patch)
treefabbe8f2db127833661563e89f245d4f4420daf4 /sci-chemistry
parentprofiles/arch/powerpc/ppc64/64le: fix openjfx mask (diff)
downloadgentoo-94ad7eb2a2a84490626fe423556e8c15bb93a8b6.tar.gz
gentoo-94ad7eb2a2a84490626fe423556e8c15bb93a8b6.tar.bz2
gentoo-94ad7eb2a2a84490626fe423556e8c15bb93a8b6.zip
sci-chemistry/autodock_vina: Fix build w/ boost-1.69
Closes: https://bugs.gentoo.org/789702 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild b/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
index 354d80938d42..19a6a106be73 100644
--- a/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
+++ b/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,15 +33,14 @@ src_prepare() {
}
src_configure() {
- use debug || c_options="-DNDEBUG"
- append-cxxflags -DBOOST_FILESYSTEM_VERSION=3
+ append-cxxflags -DBOOST_FILESYSTEM_VERSION=3 -std=c++11
}
src_compile() {
emake \
BASE="${EPREFIX}"/usr/ \
GPP="$(tc-getCXX)" \
- C_OPTIONS="${c_options}"
+ C_OPTIONS=$(usex debug '' -DNDEBUG)
}
src_install() {