summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-18 14:01:19 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-18 14:03:48 +0000
commitd45914d8382015cd695156736461a2e3e0d513f8 (patch)
treef3af3aa7de8eb362b1a5c8f9db711daa49590b04 /sci-chemistry
parentsci-chemistry/tinker: Version Bump (diff)
downloadgentoo-d45914d8382015cd695156736461a2e3e0d513f8.tar.gz
gentoo-d45914d8382015cd695156736461a2e3e0d513f8.tar.bz2
gentoo-d45914d8382015cd695156736461a2e3e0d513f8.zip
sci-chemistry/namd: Bump to EAPI=6
* drop old * Fix for new RPC siutation * fix for new hash algos Closes: https://bugs.gentoo.org/638354 Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/namd/Manifest3
-rw-r--r--sci-chemistry/namd/files/namd-2.10-gentoo.patch2
-rw-r--r--sci-chemistry/namd/metadata.xml2
-rw-r--r--sci-chemistry/namd/namd-2.10.ebuild36
-rw-r--r--sci-chemistry/namd/namd-2.9-r1.ebuild104
5 files changed, 24 insertions, 123 deletions
diff --git a/sci-chemistry/namd/Manifest b/sci-chemistry/namd/Manifest
index 80b19cddaea7..6048fce70102 100644
--- a/sci-chemistry/namd/Manifest
+++ b/sci-chemistry/namd/Manifest
@@ -1,2 +1 @@
-DIST NAMD_2.10_Source.tar.gz 9200234 SHA256 a5282c172524c2fbe6b9ba56f2de8c84f1093405c914ffbc70442dd0dd4e4289 SHA512 3712a03841fad76c502ac4e41469162ff78e6152560d0f6855d61d2b5583241a661e2a3e7446029b56a6f6f1100f25cb51b2c3df6571542397961d3bb625bc92 WHIRLPOOL b97e47c1d73d505620c26a2eca2e2e91807ebeff19e8820d9be7ea6ddd84c59cd5839846a18a2615ae993a1a6fc22b90e5080cf9d8a72aa412f6b81354e0f284
-DIST NAMD_2.9_Source.tar.gz 8814042 SHA256 9ba6a1f87d4600a62847728d7c223295be214f9a72b5bb62552f74d644108424 SHA512 0644814a2799b560d9dcf807ba0047325bc9f0a26e3831b0465d95180784f038d69595e036daac85d59cd919c92d11a0343031975d99deb1fa3052c8a649bdd6 WHIRLPOOL 5494ccb2ee2f2792fe52ad7dcfe6da9d11453f0a9b0859d30698dea56b00d92fae73465967f82bd708abee5cd4ff50b0a6ffde86451e859e2f515af203e09286
+DIST NAMD_2.10_Source.tar 35287040 BLAKE2B cc48198cd5f0490709899dd1e3c819c2caaf6f160bc5b5d7b77a18fdb63a4b9e365c99169ce8b19eb5ad139d4adb10e350985bc31f43b0abf965cb0d494fd84f SHA512 86ac830446436ad695ae61c2fb5857385f9aee01ee38be648a08d00834fd037f7da0ac4b442fcb81ca9e4ebd328344c296d0d810b8cc26ced8408be488c90b5a
diff --git a/sci-chemistry/namd/files/namd-2.10-gentoo.patch b/sci-chemistry/namd/files/namd-2.10-gentoo.patch
index e578c131c36d..ffef6dc3ad68 100644
--- a/sci-chemistry/namd/files/namd-2.10-gentoo.patch
+++ b/sci-chemistry/namd/files/namd-2.10-gentoo.patch
@@ -22,7 +22,7 @@ diff -Naur NAMD_2.10_Source.orig/arch/Linux-x86_64.tcl NAMD_2.10_Source/arch/Lin
TCLINCL=-I$(TCLDIR)/include
#TCLLIB=-L$(TCLDIR)/lib -ltcl8.5 -ldl
-TCLLIB=-L$(TCLDIR)/lib -ltcl8.5 -ldl -lpthread
-+TCLLIB=-L$(TCLDIR)/gentoo-libdir -ltcl8.5 -ldl -lpthread
++#TCLLIB=-L$(TCLDIR)/gentoo-libdir -ltcl8.5 -ldl -lpthread
TCLFLAGS=-DNAMD_TCL
TCL=$(TCLINCL) $(TCLFLAGS)
diff --git a/sci-chemistry/namd/metadata.xml b/sci-chemistry/namd/metadata.xml
index dc42d24f9afb..2fe5325ae7fa 100644
--- a/sci-chemistry/namd/metadata.xml
+++ b/sci-chemistry/namd/metadata.xml
@@ -5,7 +5,7 @@
<email>nicolasbock@gentoo.org</email>
<name>Nicolas Bock</name>
</maintainer>
-<maintainer type="project">
+ <maintainer type="project">
<email>sci-chemistry@gentoo.org</email>
<name>Gentoo Chemistry Project</name>
</maintainer>
diff --git a/sci-chemistry/namd/namd-2.10.ebuild b/sci-chemistry/namd/namd-2.10.ebuild
index d67280b8d0f1..624d3292621d 100644
--- a/sci-chemistry/namd/namd-2.10.ebuild
+++ b/sci-chemistry/namd/namd-2.10.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
+MY_PN="NAMD"
inherit eutils multilib toolchain-funcs flag-o-matic
DESCRIPTION="A powerful and highly parallelized molecular dynamics code"
-LICENSE="namd"
HOMEPAGE="http://www.ks.uiuc.edu/Research/namd/"
+SRC_URI="${MY_PN}_${PV}_Source.tar"
-MY_PN="NAMD"
-
-SRC_URI="${MY_PN}_${PV}_Source.tar.gz"
-
+LICENSE="namd"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
@@ -25,6 +24,7 @@ RDEPEND="
dev-lang/tcl:0="
DEPEND="${RDEPEND}
+ virtual/pkgconfig
app-shells/tcsh"
NAMD_ARCH="Linux-x86_64-g++"
@@ -33,6 +33,13 @@ NAMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageN
S="${WORKDIR}/${MY_PN}_${PV}_Source"
+PATCHES=(
+ # apply a few small fixes to make NAMD compile and
+ # link to the proper libraries
+ "${FILESDIR}"/namd-2.10-gentoo.patch
+ "${FILESDIR}"/namd-2.7-iml-dec.patch
+)
+
pkg_nofetch() {
echo
einfo "Please download ${MY_PN}_${PV}_Source.tar.gz from"
@@ -46,16 +53,14 @@ pkg_nofetch() {
src_prepare() {
CHARM_VERSION=$(best_version sys-cluster/charm | cut -d- -f3)
- # apply a few small fixes to make NAMD compile and
- # link to the proper libraries
- epatch "${FILESDIR}"/namd-2.10-gentoo.patch
- epatch "${FILESDIR}"/namd-2.7-iml-dec.patch
+ default
+
sed \
-e "/CHARMBASE =/s:= .*:= /usr/bin/charm-${CHARM_VERSION}:" \
-i Make.charm || die
# Remove charm distribution. We don't need it.
- rm -f charm-*.tar
+ rm -f charm-*.tar || die
# proper compiler and cflags
sed \
@@ -80,13 +85,14 @@ src_configure() {
src_compile() {
# build namd
- cd "${S}/${NAMD_ARCH}"
- emake
+ cd "${S}/${NAMD_ARCH}" || die
+ TCLLIB="$($(tc-getPKG_CONFIG) --libs tcl) -ldl -pthread" \
+ emake
}
src_install() {
dodoc announce.txt license.txt notes.txt
- cd "${S}/${NAMD_ARCH}"
+ cd "${S}/${NAMD_ARCH}" || die
# the binaries
dobin ${PN}2 psfgen flipbinpdb flipdcd
diff --git a/sci-chemistry/namd/namd-2.9-r1.ebuild b/sci-chemistry/namd/namd-2.9-r1.ebuild
deleted file mode 100644
index 869c1ec2f182..000000000000
--- a/sci-chemistry/namd/namd-2.9-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A powerful and highly parallelized molecular dynamics code"
-LICENSE="namd"
-HOMEPAGE="http://www.ks.uiuc.edu/Research/namd/"
-
-MY_PN="NAMD"
-
-SRC_URI="${MY_PN}_${PV}_Source.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RESTRICT="fetch"
-
-RDEPEND="
- >=sys-cluster/charm-6.5.1-r2
- sci-libs/fftw:3.0
- dev-lang/tcl:0="
-
-DEPEND="${RDEPEND}
- app-shells/tcsh"
-
-NAMD_ARCH="Linux-x86_64-g++"
-
-NAMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=NAMD"
-
-S="${WORKDIR}/${MY_PN}_${PV}_Source"
-
-pkg_nofetch() {
- echo
- einfo "Please download ${MY_PN}_${PV}_Source.tar.gz from"
- einfo "${NAMD_DOWNLOAD}"
- einfo "after agreeing to the license and then move it to"
- einfo "${DISTDIR}"
- einfo "Be sure to select the ${PV} version!"
- echo
-}
-
-src_prepare() {
- CHARM_VERSION=$(best_version sys-cluster/charm | cut -d- -f3)
-
- # apply a few small fixes to make NAMD compile and
- # link to the proper libraries
- epatch "${FILESDIR}"/namd-2.9-gentoo.patch
- epatch "${FILESDIR}"/namd-2.7-iml-dec.patch
- sed \
- -e "s:charm-.\+:charm-${CHARM_VERSION}:" \
- -i Make.charm || die
-
- # Remove charm distribution. We don't need it.
- rm -f charm-6.4.0.tar || die
-
- # proper compiler and cflags
- sed \
- -e "s/g++.*/$(tc-getCXX)/" \
- -e "s/gcc.*/$(tc-getCC)/" \
- -e "s/CXXOPTS = .*/CXXOPTS = ${CXXFLAGS} ${LDFLAGS}/" \
- -e "s/COPTS = .*/COPTS = ${CFLAGS} ${LDFLAGS}/" \
- -i arch/${NAMD_ARCH}.arch || die
-
- sed \
- -e "s/gentoo-libdir/$(get_libdir)/g" \
- -e "s/gentoo-charm/charm-${CHARM_VERSION}/g" \
- -i Makefile || die "Failed gentooizing Makefile."
- sed -e "s@/lib@/$(get_libdir)@g" -e '/FFTDIR=/s@=.*@=/usr@' -i arch/Linux-x86_64.fftw3 || die
- sed -e "s/gentoo-libdir/$(get_libdir)/g" -i arch/Linux-x86_64.tcl || die
-}
-
-src_configure() {
- # configure
- ./config ${NAMD_ARCH} --with-fftw3 --charm-arch . || die
-}
-
-src_compile() {
- # build namd
- cd "${S}/${NAMD_ARCH}"
- emake
-}
-
-src_install() {
- dodoc announce.txt license.txt notes.txt
- cd "${S}/${NAMD_ARCH}"
-
- # the binaries
- dobin ${PN}2 psfgen flipbinpdb flipdcd
-}
-
-pkg_postinst() {
- echo
- einfo "For detailed instructions on how to run and configure"
- einfo "NAMD please consults the extensive documentation at"
- einfo "http://www.ks.uiuc.edu/Research/namd/"
- einfo "and the NAMD tutorials available at"
- einfo "http://www.ks.uiuc.edu/Training/Tutorials/"
- einfo "Have fun :)"
- echo
-}