summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 08:36:42 +0000
committerSam James <sam@gentoo.org>2023-02-17 08:51:23 +0000
commite8fe5237502e4ada08a0df25417e3a0c896d4d97 (patch)
treeead7b90dd31a1f5753d6a16fbcc8ebdb645d48b1 /sci-chemistry
parentdev-python/pytest-shutil: drop py2 cruft (diff)
downloadgentoo-e8fe5237502e4ada08a0df25417e3a0c896d4d97.tar.gz
gentoo-e8fe5237502e4ada08a0df25417e3a0c896d4d97.tar.bz2
gentoo-e8fe5237502e4ada08a0df25417e3a0c896d4d97.zip
sci-chemistry/autodock: simplify stubbed out test/py2 cruft
Leave the non-trivial bit but the rest is obvious and could be restored easily. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/autodock/autodock-4.2.6.ebuild38
1 files changed, 15 insertions, 23 deletions
diff --git a/sci-chemistry/autodock/autodock-4.2.6.ebuild b/sci-chemistry/autodock/autodock-4.2.6.ebuild
index b4dce2e439b4..ba012304d26e 100644
--- a/sci-chemistry/autodock/autodock-4.2.6.ebuild
+++ b/sci-chemistry/autodock/autodock-4.2.6.ebuild
@@ -1,12 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# Tests require python2
-#PYTHON_COMPAT=( python2_7 )
-
-inherit autotools readme.gentoo-r1 #python-any-r1
+inherit autotools readme.gentoo-r1
MY_PN="autodocksuite"
MY_P="${MY_PN}-${PV}"
@@ -14,23 +11,18 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="A suite of automated docking tools"
HOMEPAGE="http://autodock.scripps.edu/"
SRC_URI="http://autodock.scripps.edu/downloads/autodock-registration/tars/dist$(ver_rs 1- '')/${MY_P}-src.tar.gz"
+S="${WORKDIR}/src"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
-IUSE="examples openmp" #test
-#RESTRICT="!test? ( test )"
+IUSE="examples openmp"
+# Tests require python2
+RESTRICT="test"
# False positives caused by nested configure scripts
QA_CONFIGURE_OPTIONS=".*"
-RDEPEND=""
-DEPEND=""
-#DEPEND="test? ( ${PYTHON_DEPS} )"
-
-S="${WORKDIR}/src"
-
DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="
The AutoDock development team requests all users to fill out the
@@ -76,15 +68,15 @@ src_compile() {
emake -C autogrid
}
-#src_test() {
-# elog "Testing autodock"
-# cd "${S}/autodock/Tests" || die
-# cp ../*.dat . || die
-# ${EPYTHON} test_autodock4.py || die "AutoDock tests failed."
-# einfo "Testing autogrid"
-# cd "${S}/autogrid/Tests" || die
-# ${EPYTHON} test_autogrid4.py || die "AutoGrid tests failed."
-#}
+src_test() {
+ elog "Testing autodock"
+ cd "${S}/autodock/Tests" || die
+ cp ../*.dat . || die
+ ${EPYTHON} test_autodock4.py || die "AutoDock tests failed."
+ einfo "Testing autogrid"
+ cd "${S}/autogrid/Tests" || die
+ ${EPYTHON} test_autogrid4.py || die "AutoGrid tests failed."
+}
src_install() {
if use openmp; then