summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-02 11:51:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-02 12:21:45 +0200
commit45c8c215964ea702481285cb7a4a3551492da453 (patch)
tree89f0de8ef0a1600b67a0f1f08632f650c160120f /sci-electronics/Stage/Stage-4.3.0.ebuild
parentdev-ros/pointcloud_to_laserscan: Bump to 1.3.1 (diff)
downloadgentoo-45c8c215964ea702481285cb7a4a3551492da453.tar.gz
gentoo-45c8c215964ea702481285cb7a4a3551492da453.tar.bz2
gentoo-45c8c215964ea702481285cb7a4a3551492da453.zip
sci-electronics/Stage: Bump to 4.3.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-electronics/Stage/Stage-4.3.0.ebuild')
-rw-r--r--sci-electronics/Stage/Stage-4.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-electronics/Stage/Stage-4.3.0.ebuild b/sci-electronics/Stage/Stage-4.3.0.ebuild
new file mode 100644
index 000000000000..eb8323affe49
--- /dev/null
+++ b/sci-electronics/Stage/Stage-4.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/rtv/Stage"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/rtv/Stage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Stage Robot Simulator"
+HOMEPAGE="http://rtv.github.io/Stage/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libltdl:0
+ virtual/jpeg:0
+ media-libs/libpng:0=
+ sys-libs/zlib:0=
+ x11-libs/fltk[opengl]
+ virtual/glu
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/libdir.patch" )