summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/Stage
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/Stage')
-rw-r--r--sci-electronics/Stage/Manifest1
-rw-r--r--sci-electronics/Stage/Stage-4.1.1.ebuild38
-rw-r--r--sci-electronics/Stage/Stage-9999.ebuild38
-rw-r--r--sci-electronics/Stage/metadata.xml11
4 files changed, 88 insertions, 0 deletions
diff --git a/sci-electronics/Stage/Manifest b/sci-electronics/Stage/Manifest
new file mode 100644
index 000000000000..60d4bccba803
--- /dev/null
+++ b/sci-electronics/Stage/Manifest
@@ -0,0 +1 @@
+DIST Stage-4.1.1.tar.gz 1014322 SHA256 0f115024db427a72c92c85d0987ca10b8dbc55fd756ae7f51e0277c389039498 SHA512 db39135ab2b93925dd0bfbec19d8c2820e3d6ba7caf3cf5f4b617fbdfa76b720ad99f21fde0a08559ab905d819325f5391b29deb7b6af7bb72f522ac15eb5bf2 WHIRLPOOL 7305f903ac7fea4798d11abe64774b401659ace0b5ea840b339c6433bf68da5712abbeeee0f031e668da3f00c2529c15f0a854b38cea2f6780d854658c611e8b
diff --git a/sci-electronics/Stage/Stage-4.1.1.ebuild b/sci-electronics/Stage/Stage-4.1.1.ebuild
new file mode 100644
index 000000000000..424c575679c9
--- /dev/null
+++ b/sci-electronics/Stage/Stage-4.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/rtv/Stage"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/rtv/Stage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Stage Robot Simulator"
+HOMEPAGE="http://rtv.github.io/Stage/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libltdl:0
+ virtual/jpeg:0
+ media-libs/libpng:0=
+ x11-libs/fltk
+ virtual/glu
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/sci-electronics/Stage/Stage-9999.ebuild b/sci-electronics/Stage/Stage-9999.ebuild
new file mode 100644
index 000000000000..424c575679c9
--- /dev/null
+++ b/sci-electronics/Stage/Stage-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/rtv/Stage"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/rtv/Stage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Stage Robot Simulator"
+HOMEPAGE="http://rtv.github.io/Stage/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libltdl:0
+ virtual/jpeg:0
+ media-libs/libpng:0=
+ x11-libs/fltk
+ virtual/glu
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/sci-electronics/Stage/metadata.xml b/sci-electronics/Stage/metadata.xml
new file mode 100644
index 000000000000..464271f6d8f2
--- /dev/null
+++ b/sci-electronics/Stage/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rtv/Stage</remote-id>
+ </upstream>
+</pkgmetadata>