summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-24 18:39:28 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-24 18:40:06 +0300
commitbd3e4d8ba482580f3db048d241aee4c4e65c5c6e (patch)
treede33b607529c35396d41ba2012e5364d5b2063bd /sci-electronics/fasthenry
parentsys-boot/cromwell: Port to EAPI 7 (diff)
downloadgentoo-bd3e4d8ba482580f3db048d241aee4c4e65c5c6e.tar.gz
gentoo-bd3e4d8ba482580f3db048d241aee4c4e65c5c6e.tar.bz2
gentoo-bd3e4d8ba482580f3db048d241aee4c4e65c5c6e.zip
sci-electronics/fasthenry: Fix ar
Closes: https://bugs.gentoo.org/750128 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-electronics/fasthenry')
-rw-r--r--sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild3
-rw-r--r--sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-ar.patch18
2 files changed, 20 insertions, 1 deletions
diff --git a/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
index b8691f8986a6..ee1cef974df8 100644
--- a/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
+++ b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
@@ -23,10 +23,11 @@ S=${WORKDIR}/fasthenry-3.0wr
PATCHES=(
"${FILESDIR}/${P}-cflags.patch"
"${FILESDIR}/${P}-ldflags.patch"
+ "${FILESDIR}/${P}-ar.patch"
)
src_compile() {
- tc-export CC
+ tc-export CC AR
emake all
}
diff --git a/sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-ar.patch b/sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-ar.patch
new file mode 100644
index 000000000000..ea1e671b7df1
--- /dev/null
+++ b/sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-ar.patch
@@ -0,0 +1,18 @@
+diff -ruN fasthenry-3.0wr.orig/src/sparse/Makefile fasthenry-3.0wr/src/sparse/Makefile
+--- fasthenry-3.0wr.orig/src/sparse/Makefile 2020-10-24 18:35:15.348900086 +0300
++++ fasthenry-3.0wr/src/sparse/Makefile 2020-10-24 18:37:09.729921680 +0300
+@@ -25,12 +25,12 @@
+ # $(CC) $(CFLAGS) -o $(DESTINATION) $(TESTO) $(LIBRARY) -lm
+
+ $(LIBRARY) : $(OFILES)
+- ar r $(LIBRARY) $?
++ $(AR) r $(LIBRARY) $?
+ ranlib $(LIBRARY)
+
+ spice : $(LIBRARY) spSMP.o
+ cp $(LIBRARY) ../SMP.a
+- ar r ../SMP.a spSMP.o
++ $(AR) r ../SMP.a spSMP.o
+ ranlib ../SMP.a
+
+ lint :