summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/gazebo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/Manifest1
-rw-r--r--sci-electronics/gazebo/files/bullet_283.patch41
-rw-r--r--sci-electronics/gazebo/gazebo-5.1.0.ebuild66
-rw-r--r--sci-electronics/gazebo/metadata.xml8
4 files changed, 116 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
new file mode 100644
index 000000000000..260d3567496c
--- /dev/null
+++ b/sci-electronics/gazebo/Manifest
@@ -0,0 +1 @@
+DIST gazebo5_5.1.0.tar.bz2 49544340 SHA256 eac72ca2633deb7ea0f5e775c1208f0743d98c8b53083607df77bae6e38ab0b1 SHA512 d3222d9d98cc9d1c52bc1bb24e12ece7ff8d8506782f9cd2d574a1aca8556e33d93781f4d2c91eacfe317a35c7cddfa2c4a4fdb58da1f348142f6a887de3c981 WHIRLPOOL 5e9e01195b02581d684ee0c5e30f9ace0210a7b61a59a63b7a3c01c8c672230ad026f998ed93583eafb9b640c73c9df350e578a774d9579fdb8574570fa0bd94
diff --git a/sci-electronics/gazebo/files/bullet_283.patch b/sci-electronics/gazebo/files/bullet_283.patch
new file mode 100644
index 000000000000..cc1649b10cd3
--- /dev/null
+++ b/sci-electronics/gazebo/files/bullet_283.patch
@@ -0,0 +1,41 @@
+# HG changeset patch
+# User Steve Peters <scpeters@osrfoundation.org>
+# Date 1430782295 25200
+# Branch issue_1074
+# Node ID 05b7ee5db6f524e19b6cca54d66208cb48a0854c
+# Parent 2cbd32c6246166f6f50af3503553180e7c1cd4a4
+Fix build when compiled against bullet 2.83
+
+diff --git a/gazebo/physics/bullet/BulletHinge2Joint.cc b/gazebo/physics/bullet/BulletHinge2Joint.cc
+--- a/gazebo/physics/bullet/BulletHinge2Joint.cc
++++ b/gazebo/physics/bullet/BulletHinge2Joint.cc
+@@ -211,8 +211,12 @@
+ return math::Angle();
+ }
+
+- btRotationalLimitMotor *motor =
+- this->bulletHinge2->getRotationalLimitMotor(_index);
++#ifndef LIBBULLET_VERSION_GT_282
++ btRotationalLimitMotor
++#else
++ btRotationalLimitMotor2
++#endif
++ *motor = this->bulletHinge2->getRotationalLimitMotor(_index);
+ if (motor)
+ return motor->m_hiLimit;
+
+@@ -229,8 +233,12 @@
+ return math::Angle(0.0);
+ }
+
+- btRotationalLimitMotor *motor =
+- this->bulletHinge2->getRotationalLimitMotor(_index);
++#ifndef LIBBULLET_VERSION_GT_282
++ btRotationalLimitMotor
++#else
++ btRotationalLimitMotor2
++#endif
++ *motor = this->bulletHinge2->getRotationalLimitMotor(_index);
+ if (motor)
+ return motor->m_loLimit;
+
diff --git a/sci-electronics/gazebo/gazebo-5.1.0.ebuild b/sci-electronics/gazebo/gazebo-5.1.0.ebuild
new file mode 100644
index 000000000000..d1a55a1ed8ff
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-5.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://bitbucket.org/osrf/gazebo/get/${PN}$(get_major_version)_${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 libav test"
+
+RDEPEND="
+ >=dev-libs/protobuf-2.3.0
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ dev-libs/libtar
+ dev-cpp/tbb
+ >=dev-games/ogre-1.7.4
+ sci-libs/libccd
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:= )
+ sci-libs/gts
+ >=sci-physics/bullet-2.82
+ >=dev-libs/sdformat-2.3.1
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-libs/boost:=[threads]
+ sci-libs/gdal
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:4
+ app-text/ronn
+ virtual/pkgconfig
+"
+S="${WORKDIR}/${PN}$(get_major_version)_${PV}"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=( "${FILESDIR}/bullet_283.patch" )
+
+src_configure() {
+ # doesnt build without it
+ append-cxxflags "-std=c++11"
+ # doesnt build with as-needed either
+ append-ldflags "-Wl,--no-as-needed"
+
+ has_version '>=sci-physics/bullet-2.83' && append-cppflags "-DLIBBULLET_VERSION_GT_282=1"
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DENABLE_TESTS_COMPILATION=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-electronics/gazebo/metadata.xml b/sci-electronics/gazebo/metadata.xml
new file mode 100644
index 000000000000..e7dd05f66879
--- /dev/null
+++ b/sci-electronics/gazebo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>aballier@gentoo.org</email>
+<name>Alexis Ballier</name>
+</maintainer>
+</pkgmetadata>