summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-06-08 13:48:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-06-08 14:26:27 +0200
commit723152a8a0e8eb9059b36c2d39f0836eb917754d (patch)
tree17951ddb6d750a883de9c47e9cbb789ff3d292d7 /sci-electronics/gazebo
parentsci-electronics/gazebo: Remove old (diff)
downloadgentoo-723152a8a0e8eb9059b36c2d39f0836eb917754d.tar.gz
gentoo-723152a8a0e8eb9059b36c2d39f0836eb917754d.tar.bz2
gentoo-723152a8a0e8eb9059b36c2d39f0836eb917754d.zip
sci-electronics/gazebo: bump to 9.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/Manifest1
-rw-r--r--sci-electronics/gazebo/gazebo-9.1.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index 5a61ca67a978..3e92ee627852 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1 +1,2 @@
DIST gazebo-9.0.0.tar.bz2 52779811 BLAKE2B a85c9fd0e4b805e28ea8fb71c068ad53f18db91a474631b5da73a2a565181c8c22270742c9fabf1656d322fd63ba1caac3286b992d7dc7b197a0582ed724d06e SHA512 52394445d34ce24b2036102be08b6b626fb7021dd0ebaab8e588b68e1e0790d2e26ed2af8ead8f37b0c2e2d37c3d7fc22f95b0b2a8bd95e8dcd77e7fb296dd50
+DIST gazebo-9.1.0.tar.bz2 52928923 BLAKE2B 2b152964d649a3eb572b96bbb27e8f6795bddd5347f893f200d97a80f4c0d8128d548d87dfa3e5051b9aa3af6a4a6be56e79f05252cc6f17278ef2c1592cfb0e SHA512 9ea27cf802e6ce657fe98c886f9d4582303abcec83f6be5e27980969564ec69f42c9589586baa19ea4fd514c3385b9b263f7205a0510b42414c90c1de7cbfd29
diff --git a/sci-electronics/gazebo/gazebo-9.1.0.ebuild b/sci-electronics/gazebo/gazebo-9.1.0.ebuild
new file mode 100644
index 000000000000..76ad65771aa8
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-9.1.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# Subslot = major version = soname of libs
+SLOT="0/9"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 libav test"
+
+RDEPEND="
+ >=dev-libs/protobuf-2:=
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ >=dev-libs/tinyxml2-6:=
+ dev-libs/libtar
+ dev-cpp/tbb
+ >=dev-games/ogre-1.7.4[freeimage]
+ >=media-libs/freeimage-3.15.4[png]
+ sci-libs/libccd
+ libav? ( >=media-video/libav-9:0= )
+ !libav? ( >=media-video/ffmpeg-2.6:0= )
+ sci-libs/gts
+ >=sci-physics/bullet-2.82
+ >=dev-libs/sdformat-6.0:=
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5
+ dev-libs/boost:=[threads]
+ sci-libs/gdal:=
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+ sci-libs/hdf5:=[cxx]
+ sys-apps/util-linux
+ media-gfx/graphviz
+ net-libs/ignition-msgs:1=
+ sci-libs/ignition-math:4=
+ net-libs/ignition-transport:4=
+ x11-libs/qwt:6=[qt5]
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ app-text/ronn
+ app-arch/gzip
+ virtual/pkgconfig
+ x11-apps/mesa-progs
+ test? ( dev-libs/libxslt )
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=( "${FILESDIR}/qwt.patch" )
+
+src_configure() {
+ # doesnt build without it
+ append-cxxflags "-std=c++11"
+ # doesnt build with as-needed either
+ append-ldflags "-Wl,--no-as-needed"
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DBUILD_TESTING=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ "-DUSE_EXTERNAL_TINYXML2=TRUE"
+ )
+ cmake-utils_src_configure
+}