summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-28 12:14:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-28 13:54:33 +0100
commitcd2675166e9239bfc8206953a6b4e9857b6a5661 (patch)
treef20b2b29a7c3678a190912bb4ffd8b194b46eac6 /sci-electronics/gazebo
parentnet-libs/ignition-transport: bump to 4.0.0 (diff)
downloadgentoo-cd2675166e9239bfc8206953a6b4e9857b6a5661.tar.gz
gentoo-cd2675166e9239bfc8206953a6b4e9857b6a5661.tar.bz2
gentoo-cd2675166e9239bfc8206953a6b4e9857b6a5661.zip
sci-electronics/gazebo: bump to 9.0.0
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/Manifest1
-rw-r--r--sci-electronics/gazebo/gazebo-9.0.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index 75e2a1711ea7..2599468bfd5c 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1 +1,2 @@
DIST gazebo-8.2.0.tar.bz2 52513092 BLAKE2B d44c4ac837163331f50e266bb4880f42fff82037ccc9a7e1ac7ccea0a37415a2fc217c62b449358510308fc741e0c569e2613c70c328e323f6f018c5bc6f0b31 SHA512 d2561a6e5460ea068d9c84945e5955d986bc1f6f0d1ba16100aae53015c6e11da3a152ac6ecb906147d37261d4c680025bcc5f5587c6c09f127319dc184cf843
+DIST gazebo-9.0.0.tar.bz2 52779811 BLAKE2B a85c9fd0e4b805e28ea8fb71c068ad53f18db91a474631b5da73a2a565181c8c22270742c9fabf1656d322fd63ba1caac3286b992d7dc7b197a0582ed724d06e SHA512 52394445d34ce24b2036102be08b6b626fb7021dd0ebaab8e588b68e1e0790d2e26ed2af8ead8f37b0c2e2d37c3d7fc22f95b0b2a8bd95e8dcd77e7fb296dd50
diff --git a/sci-electronics/gazebo/gazebo-9.0.0.ebuild b/sci-electronics/gazebo/gazebo-9.0.0.ebuild
new file mode 100644
index 000000000000..5c58345f2621
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-9.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# Subslot = major version = soname of libs
+SLOT="0/8"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 libav test"
+
+RDEPEND="
+ >=dev-libs/protobuf-2:=
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ >=dev-libs/tinyxml2-6:=
+ dev-libs/libtar
+ dev-cpp/tbb
+ >=dev-games/ogre-1.7.4[freeimage]
+ >=media-libs/freeimage-3.15.4[png]
+ sci-libs/libccd
+ libav? ( >=media-video/libav-9:0= )
+ !libav? ( >=media-video/ffmpeg-2.6:0= )
+ sci-libs/gts
+ >=sci-physics/bullet-2.82
+ >=dev-libs/sdformat-6.0:=
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5
+ dev-libs/boost:=[threads]
+ sci-libs/gdal:=
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+ sci-libs/hdf5:=[cxx]
+ sys-apps/util-linux
+ media-gfx/graphviz
+ net-libs/ignition-msgs:1=
+ sci-libs/ignition-math:4=
+ net-libs/ignition-transport:4=
+ x11-libs/qwt:6=[qt5]
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ app-text/ronn
+ app-arch/gzip
+ virtual/pkgconfig
+ x11-apps/mesa-progs
+ test? ( dev-libs/libxslt )
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=( "${FILESDIR}/qwt.patch" )
+
+src_configure() {
+ # doesnt build without it
+ append-cxxflags "-std=c++11"
+ # doesnt build with as-needed either
+ append-ldflags "-Wl,--no-as-needed"
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DBUILD_TESTING=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ "-DUSE_EXTERNAL_TINYXML2=TRUE"
+ )
+ cmake-utils_src_configure
+}