summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-28 17:36:55 +0000
committerSam James <sam@gentoo.org>2021-02-28 17:39:07 +0000
commit123a8fca20c9ad42fef0d58e2312bb7e65caab55 (patch)
tree9f8c8db57dc568faf0d16631e8a60f0d2c42a7a0 /sci-electronics/iverilog
parentsci-electronics/iverilog: Revert "remove old" (diff)
downloadgentoo-123a8fca20c9ad42fef0d58e2312bb7e65caab55.tar.gz
gentoo-123a8fca20c9ad42fef0d58e2312bb7e65caab55.tar.bz2
gentoo-123a8fca20c9ad42fef0d58e2312bb7e65caab55.zip
sci-electronics/iverilog: cleanup old where possible
Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics/iverilog')
-rw-r--r--sci-electronics/iverilog/iverilog-10.3-r1.ebuild75
-rw-r--r--sci-electronics/iverilog/iverilog-10.3-r2.ebuild71
2 files changed, 0 insertions, 146 deletions
diff --git a/sci-electronics/iverilog/iverilog-10.3-r1.ebuild b/sci-electronics/iverilog/iverilog-10.3-r1.ebuild
deleted file mode 100644
index 8a107b99189d..000000000000
--- a/sci-electronics/iverilog/iverilog-10.3-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-GITHUB_PV=$(ver_rs 1- '_')
-
-DESCRIPTION="A Verilog simulation and synthesis tool"
-HOMEPAGE="
- http://iverilog.icarus.com
- https://github.com/steveicarus/iverilog
-"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/steveicarus/${PN}.git"
-else
- SRC_URI="https://github.com/steveicarus/${PN}/archive/v${GITHUB_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
- S="${WORKDIR}/${PN}-${GITHUB_PV}"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="examples"
-
-# If you are building from git, you will also need gperf to generate
-# the configure scripts.
-RDEPEND="
- sys-libs/readline:=
- sys-libs/zlib
-"
-
-DEPEND="
- dev-util/gperf
- sys-devel/bison
- sys-devel/flex
- ${RDEPEND}
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-10.3-file-missing.patch #705412
- "${FILESDIR}"/${PN}-10.3-fno-common.patch #706366
-)
-
-src_prepare() {
- default
-
- # From upstreams autoconf.sh, to make it utilize the autotools eclass
- # Here translate the autoconf.sh, equivalent to the following code
- # > sh autoconf.sh
-
- # Autoconf in root ...
- eautoconf --force
- # Precompiling lexor_keyword.gperf
- gperf -o -i 7 -C -k 1-4,6,9,\$ -H keyword_hash -N check_identifier -t ./lexor_keyword.gperf > lexor_keyword.cc || die
- # Precompiling vhdlpp/lexor_keyword.gperf
- cd vhdlpp || die
- gperf -o -i 7 --ignore-case -C -k 1-4,6,9,\$ -H keyword_hash -N check_identifier -t ./lexor_keyword.gperf > lexor_keyword.cc || die
-}
-
-src_install() {
- local DOCS=( *.txt )
- # Default build fails with parallel jobs,
- # https://github.com/steveicarus/iverilog/pull/294
- emake installdirs DESTDIR="${D}"
- default
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/sci-electronics/iverilog/iverilog-10.3-r2.ebuild b/sci-electronics/iverilog/iverilog-10.3-r2.ebuild
deleted file mode 100644
index be0e76900950..000000000000
--- a/sci-electronics/iverilog/iverilog-10.3-r2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-GITHUB_PV=$(ver_rs 1- '_')
-
-DESCRIPTION="A Verilog simulation and synthesis tool"
-HOMEPAGE="
- http://iverilog.icarus.com
- https://github.com/steveicarus/iverilog
-"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/steveicarus/${PN}.git"
-else
- SRC_URI="https://github.com/steveicarus/${PN}/archive/v${GITHUB_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
- S="${WORKDIR}/${PN}-${GITHUB_PV}"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-DEPEND="
- sys-libs/readline:=
- sys-libs/zlib
-"
-RDEPEND="${DEPEND}"
-BDEPEND="dev-util/gperf
- sys-devel/bison
- sys-devel/flex
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-10.3-file-missing.patch #705412
- "${FILESDIR}"/${PN}-10.3-fno-common.patch #706366
- "${FILESDIR}"/${PN}-10.3-gen-bison-header.patch #734760
-)
-
-src_prepare() {
- default
-
- # From upstreams autoconf.sh, to make it utilize the autotools eclass
- # Here translate the autoconf.sh, equivalent to the following code
- # > sh autoconf.sh
-
- # Autoconf in root ...
- eautoconf
-
- # Precompiling lexor_keyword.gperf
- gperf -o -i 7 -C -k 1-4,6,9,\$ -H keyword_hash -N check_identifier -t ./lexor_keyword.gperf > lexor_keyword.cc || die
- # Precompiling vhdlpp/lexor_keyword.gperf
- cd vhdlpp || die
- gperf -o -i 7 --ignore-case -C -k 1-4,6,9,\$ -H keyword_hash -N check_identifier -t ./lexor_keyword.gperf > lexor_keyword.cc || die
-}
-
-src_install() {
- local DOCS=( *.txt )
-
- # Default build fails with parallel jobs,
- # https://github.com/steveicarus/iverilog/pull/294
- emake installdirs DESTDIR="${ED}"
- default
-
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
-}