summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-06 18:11:53 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-06 18:12:50 +0100
commitbdcba22394cc15d3ee2a8b24cfa94e6d9e84ef2f (patch)
treebb106c29fdc9988f0377bbfd73b79e0e453b31bd /sci-electronics/kicad/kicad-4.0.4.ebuild
parentapp-doc/gnucash-docs: Bump and add maintainer (diff)
downloadgentoo-bdcba22394cc15d3ee2a8b24cfa94e6d9e84ef2f.tar.gz
gentoo-bdcba22394cc15d3ee2a8b24cfa94e6d9e84ef2f.tar.bz2
gentoo-bdcba22394cc15d3ee2a8b24cfa94e6d9e84ef2f.zip
sci-electronics/kicad: Backport L10N migration also to stable ebuild.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-electronics/kicad/kicad-4.0.4.ebuild')
-rw-r--r--sci-electronics/kicad/kicad-4.0.4.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-electronics/kicad/kicad-4.0.4.ebuild b/sci-electronics/kicad/kicad-4.0.4.ebuild
index 0a61360b4868..6c75dc7aba9b 100644
--- a/sci-electronics/kicad/kicad-4.0.4.ebuild
+++ b/sci-electronics/kicad/kicad-4.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -26,12 +26,11 @@ LICENSE="GPL-2+ GPL-3+ Boost-1.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug doc examples github i18n libressl minimal +python"
-LANGS="bg ca cs de el es fi fr hu it ja ko nl pl pt ru sk sl sv zh_CN"
+LANGS="bg ca cs de el es fi fr hu it ja ko nl pl pt ru sk sl sv zh-CN"
for lang in ${LANGS} ; do
- IUSE="${IUSE} linguas_${lang}"
+ IUSE="${IUSE} l10n_${lang}"
done
unset lang
-unset LANGS
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )"
@@ -104,10 +103,11 @@ src_prepare() {
ln -s "${WORKDIR}/${P}-i18n" "${S}/${PN}-i18n" || die
# Remove unused languages. Project generates only languages specified in the
# file in LINGUAS in the subproject folder. By default all languages are added
- # so we sed out the unused ones based on the user linguas_* settings.
+ # so we sed out the unused ones based on the user l10n_* settings.
local lang
for lang in ${LANGS}; do
- if ! use linguas_${lang}; then
+ if ! use l10n_${lang}; then
+ lang="${lang//-/_}"
sed "/${lang}/d" -i ${PN}-i18n/LINGUAS || die
fi
done