summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2019-12-06 15:44:21 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-12-08 12:08:16 +0200
commit8f90db01149b47e7469b8b3a6311a1f2af041955 (patch)
tree04f57bf0cbf063bf65b0039f2c16029016cbd8eb /sci-electronics/librepcb
parentnet-misc/openntpd: EAPI=7, Use GLEP 81 for user/group instead of user eclass (diff)
downloadgentoo-8f90db01149b47e7469b8b3a6311a1f2af041955.tar.gz
gentoo-8f90db01149b47e7469b8b3a6311a1f2af041955.tar.bz2
gentoo-8f90db01149b47e7469b8b3a6311a1f2af041955.zip
sci-electronics/librepcb: bump version to 0.1.3
Bump version to 0.1.3 Add linguist-tools to BDEPEND Closes: https://bugs.gentoo.org/696546 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/13837 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-electronics/librepcb')
-rw-r--r--sci-electronics/librepcb/Manifest1
-rw-r--r--sci-electronics/librepcb/librepcb-0.1.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-electronics/librepcb/Manifest b/sci-electronics/librepcb/Manifest
index eaf40b69966a..e0cf1b45069b 100644
--- a/sci-electronics/librepcb/Manifest
+++ b/sci-electronics/librepcb/Manifest
@@ -1 +1,2 @@
DIST librepcb-0.1.0-source.zip 12390253 BLAKE2B a44cd0ae0b27961725b01b18eb4d31a1f5f81f9f88252c6d4a7d44280e7bc262c56e99d679598e9cab0eb99c1f30f4e2887a97d72034a691f93946fbe372d6ee SHA512 c87f71743385b44763187251afb6cfa08860e20b58a2d69e4f6a1bc71765e2c49cbc6b59348b4ea089624f3cbc401872ccac1e97a5c260e866665003710cf937
+DIST librepcb-0.1.3-source.zip 12148919 BLAKE2B 2be3455c9be3e60a7cb314292e2a6ffe10d98f0c647d9c79f223ee5c5ef50675685d914889f772448dba699742d3bcd5b6636d489e630c8033912f3c9f223715 SHA512 28d45800bbbbcee8d30973c1a1e1e561c0fe2c65339eda4f6170779d921a9f5b2f5fb8c1cda00477e59976b88a3c368bb4985f31331bb16f761823642138c78b
diff --git a/sci-electronics/librepcb/librepcb-0.1.3.ebuild b/sci-electronics/librepcb/librepcb-0.1.3.ebuild
new file mode 100644
index 000000000000..50dfacb22b3c
--- /dev/null
+++ b/sci-electronics/librepcb/librepcb-0.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Free EDA software to develop printed circuit boards"
+HOMEPAGE="https://librepcb.org/"
+SRC_URI="https://download.librepcb.org/releases/${PV}/${P}-source.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+ app-arch/unzip
+ dev-qt/linguist-tools:5"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5 -r PREFIX="/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}