summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2018-07-30 16:54:27 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2018-07-30 16:57:47 +0200
commitfe8e2d343f5a9aa351759be72bae2be00c53f554 (patch)
treeef21f30ed51393acfd18ce4a33df4c97bf2d2db8 /sci-electronics/linsmith
parentmedia-radio/fldigi: Drop old (diff)
downloadgentoo-fe8e2d343f5a9aa351759be72bae2be00c53f554.tar.gz
gentoo-fe8e2d343f5a9aa351759be72bae2be00c53f554.tar.bz2
gentoo-fe8e2d343f5a9aa351759be72bae2be00c53f554.zip
sci-electronics/linsmith: Minor maintenance release
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'sci-electronics/linsmith')
-rw-r--r--sci-electronics/linsmith/Manifest1
-rw-r--r--sci-electronics/linsmith/linsmith-0.99.31.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sci-electronics/linsmith/Manifest b/sci-electronics/linsmith/Manifest
index bd57a1676e14..96f5ae647409 100644
--- a/sci-electronics/linsmith/Manifest
+++ b/sci-electronics/linsmith/Manifest
@@ -1 +1,2 @@
DIST linsmith-0.99.30.tar.gz 1132438 BLAKE2B fda024052d0aa1af7254aa37975a62bcb1bd2dbeb020202853bc32c85e6859bda6153fb5e6af8f18a4bf29a11c5eb7bd5eaacc68ebbf20b7d2622cc0d04d77d1 SHA512 d1f6cd3895b7c217de49c214f8b86b1bb9ce97d540546f0004b7f320b7cf142652cf0ec51ce48cf32b89564bf408546bf10d5f4937544cf9e8a4d87d1db5bed5
+DIST linsmith-0.99.31.tar.gz 1138998 BLAKE2B c8b32bf2530b87a0bb9f2b7914e5ccdb6c8ad28b57b919b93c4ed0fb272a2e61f588adb3794b81565580a68413f3cb4e43ac861c4a70cce105d3e821d21eccf3 SHA512 0218992243ff5db6efa39e01d7eddf6d44d921fe4caf131d020416d320a542f19bd577a3bbd9fc8df5f1ccb62ba152d02f825bab8fae55dadd262c5dce47c076
diff --git a/sci-electronics/linsmith/linsmith-0.99.31.ebuild b/sci-electronics/linsmith/linsmith-0.99.31.ebuild
new file mode 100644
index 000000000000..af9078102c2a
--- /dev/null
+++ b/sci-electronics/linsmith/linsmith-0.99.31.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="Smith charting program, mainly designed for educational use"
+HOMEPAGE="http://www.jcoppens.com/soft/linsmith/index.en.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS NOTES README THANKS TODO )
+
+src_prepare() {
+ eapply_user
+
+ # This patch is to prevent make install copying
+ # the examples in /usr/share/linsmith
+ # Now they are cp to the correct location.
+ eapply -p0 "${FILESDIR}"/${PN}-datafiles.patch
+
+ # fix QA warnings about wrong categories and location of icon file
+ # in .desktop file
+ sed -i -e "s/Application;Engineering;/Education;Science;Electronics;/" \
+ -e "s/Encoding=/#Encoding=/" \
+ -e "s#pixmaps/linsmith/l#pixmaps/l#" \
+ ${PN}.desktop || die
+
+ # fix QA warnings about 'maintainer mode'
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto "/usr/share/${PN}"
+ doins datafiles/conv0809
+
+ einstalldocs
+ doman doc/${PN}.1
+
+ domenu ${PN}.desktop
+ doicon ${PN}_icon.xpm
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins doc/manual.pdf
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins datafiles/*.circ datafiles/*.load || die
+ fi
+}